[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Problem Bridging Connections

  • To: xen-users@xxxxxxxxxxxxx
  • From: Casey DeLorme <cdelorme@xxxxxxxxx>
  • Date: Sun, 22 Apr 2012 20:44:51 -0400
  • Delivery-date: Mon, 23 Apr 2012 00:46:37 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hello Xen Users,

I need a hand with bridging network connections.

I am running Xen 4.2 with a Debian Wheezy Dom0.

My objective is to run a HVM PFSense, with eth0 to xenbr0 as WAN and xenbr1 to eth1 as LAN, and I want Dom0 inside the network (part of LAN not WAN).

As far as I can tell it is working, a Windows 7 x64 HVM and a Debian Squeeze HVM both have Internet access using xenbr1, and eth1 is wired to a switch where five additional devices also have Internet access.

However, Dom0 does not receive a connection at all, and has no access inside the LAN or to the Internet.

The basic appearance of my /etc/network/interfaces:

auto lo xenbr0 xenbr1
iface lo inet loopback
iface eth0 inet manual
iface eth1 inet manual
iface xenbr0 inet manual
bridge_ports eth0
iface xenbr1 inet manual
bridge_ports eth1

I have tried setting a static IP on xenbr1, and eth1 to no avail.  ifconfig sees the values but no access to LAN is available.

I also tried a bridge to bridge from xenbr1 to a static bridge, also did not work.

When I set any of them to dhcp I just get a huge boot time delay because PFSense isn't running yet, and no connection even five minutes after every other device is already accessing.

Can anyone please provide a solution?


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.