[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] eth0 doesn't load on dom0 with kernel

  • To: xen-users@xxxxxxxxxxxxx
  • From: José Eduardo França <jefranca@xxxxxxxxx>
  • Date: Wed, 22 Aug 2012 08:52:42 -0300
  • Delivery-date: Wed, 22 Aug 2012 11:53:44 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hi Guys,

I'm working with:
  1. xen 4.1 installed from source (I followed this tutorial <http://wiki.xen.org/mediawiki/images/f/f1/Building_and_Installing_Xen_4.x_and_Linux_Kernel_3.x_on_Ubuntu_and_Debian_Linux_-_Version_1.7_-_REDUCED.pdf>);
  2. dom0 ubuntu server 12.04 kernel (I followed this tutorial <http://remusha.wikidot.com/#toc3>)
I'm trying to run remus with disk replication (I can run without disk replication). Coz this I am trying to use kernel I tried others kernels 3.x (see: http://xen.1045712.n5.nabble.com/How-to-install-pv-guests-with-tap2-aio-for-remus-td5710672.html) but I saw that blktap2 kernel module is not present in the mainline kernel 3.x.

The problem is: eth0 doesn't load on dom0 with kernel
I ran these commands:

       1-  $ lspci | grep -i ethernet
            02:00.0 Ethernet controller: Broadcom Corporation Netlink BCM57780 Gigabit Ethernet PCIe (rev 01)

       2-  $ lsmod

       3-  $ dmesg | grep -i eth
              "no response"

       4-  $ dmesg | grep -i eth
              "only lo"

       5-  # ifup eth0
              Cannot find device "eth0"
              Failed to bring up eth0.

Does someone have a suggestion?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.