[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] Issue with making rpm with patch applied

Hi Pasi,

I have tried with the -p options p1 and p0 which doesn't help :(

On Thu, Sep 6, 2012 at 6:16 PM, Pasi Kärkkäinen <pasik@xxxxxx> wrote:
On Thu, Sep 06, 2012 at 02:44:39PM +0530, kk s wrote:
>    Hi,
>    I have downloaded src rpm from gitco and extracted into the
>    /usr/src/redhat/SOURCES dir then downloaded the patches and renamed it as
>    properly like xen-3.4.4-xsa17-qemu-xen-traditional-all.patch. Then edited
>    the xen-x.spec file and added the patches. After that I have tried to make
>    rpm using rpmbuild -bb xen-x.spec and I ended up with the below error,
>    Patch #13 (xen-3.4.4-xsa17-qemu-xen-traditional-all.patch):
>    + patch -p1 -s
>    The text leading up to this was:
>    --------------------------
>    |console: bounds check whenever changing the cursor due to an escape code
>    |
>    |This is XSA-17 / CVE-2012-3515
>    |
>    |Signed-off-by: Ian Campbell <[1]ian.campbell@xxxxxxxxxx>
>    |
>    |diff --git a/console.c b/console.c
>    |index 5e6e3d0..9984d6f 100644
>    |--- a/console.c
>    |+++ b/console.c
>    --------------------------
>    File to patch:
>    Fyi : I have added the patches xsa12-all.patch,
>    xsa14-xen-3.4-and-4.x.patch and xsa17-qemu-xen-traditional-all.patch. All
>    the patches goes fine expect xsa17-qemu-xen-traditional-all.patch.
>    May I know how can I apply this?

With a quick look at your email it looks like wrong -p option for patch?

-- Pasi

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.