[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xen-pciback always gives error: Unknown parameter `1)'

If you are using the stock kernel and pciback as a module, then you have to use live binding, not grub.

Alternatively, rebuild the kernel with pciback built-in (not as a module) and that will allow you to use grub.

Supposedly you can rebuild the initrd image without recompiling the whole kernel, if live binding isn't appealing then I would investigate that.

On Mon, Sep 10, 2012 at 1:03 PM, Tilo Peter <phenix@xxxxxx> wrote:
I tried running debian wheezy amd64 with the debian stock kernel 3.2 and
xen 4.2 rc3. Compiling ran through without any errors and xen boots up
without problems.

But xen-pciback always produces the same error message:

# lsmod | grep pci
pci_stub               12429  0
# modprobe xen-pciback
ERROR: could not insert 'xen_pciback': Unknown symbol in module, or
unknown parameter (see dmesg)
# dmesg | tail -n 1
[ 3687.470124] xen_pciback: Unknown parameter `1)'

This message always appears when I try to load xen-pciback, whenever I
give a "hide=(0000:01.00.0)" parameter or not, or in general whatever I do.

Since I couldn't find any help on this topic so far, I hope for some
idea for a solution here!

Best Regards,

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.