[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Intel igb driver 3.2.10-k failed to work on Xen 4.1.2 kernel

  • To: xen-users@xxxxxxxxxxxxx
  • From: John Mok <jmok@xxxxxxxxxxxxx>
  • Date: Thu, 13 Sep 2012 23:23:07 +0800
  • Delivery-date: Thu, 13 Sep 2012 15:24:09 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


I tried to use Intel quad-port ethernet adapter on a server running Ubuntu 12.04.1 (kernel 3.2.27), but the igb driver (version 3.2.10-k) failed to work on Xen 4.1.2 kernel in bridge mode.

The content of /etc/network/interfaces follows :-

auto xenbr0
iface xenbr0 inet static
        address .....
        bridge_ports eth0

auto eth0
iface eth0 inet manual

I checked with brctl and there was no associated interface (i.e. eth0 was missing). The bridge interface appeared to be up and running but no traffic could go through (e.g. ping failed). I tried to add the 2nd ethernet port to the bridge and the command completed successfully, but still no traffic could pass through.

The igb driver worked normally when booted to kernel 3.2.27 (not Xen kernel).

I hope someone could advise what went wrong and how to fix it.

Thanks a lot.

John Mok

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.