[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't Start any VM's from NFS Repository

Hi Camron,

Questions about xcp are usually best addressed to the (badly named)
xen-api@ list. This list tends to deal more with users of the xl/xm
toolstacks shipped with Xen itself.


On Fri, 2012-11-09 at 09:51 +0000, Camron Lent wrote:
> I am not sure where else to turn. This is essentially what happened.
> We had an XCP 1.5 pool with 2 machines as hosts. The storage pool
> which is NFS mounted lost its ability to export the filesystem with
> the VM images on it...
> We contacted the vendor and were able to restore it. However, they had
> recommended that we delete the XCP Pool, recreate it, add the hosts
> back in, and then mount the storage.
> This is where we are now. We can see the storage and the VM images.
> However in XCP Xen Center when looking at the images it's clear that
> the metadata is lost. So we can not see which image or snap-shot
> belongs to which VM. The names are all blank when we look at the
> storage.
> I've gone down the route of randomly selecting VM's with the hope that
> I'd find the right one... because everything I've tried so far has
> failed. I am able to run the vdh-util to see the top-level VDH's and
> I've tried booting from each level to see if I can get any result. The
> same thing occurs each time. I get "The SR failed to complete the
> operation".
> I would be happy if I could just get to the data, but the snapshotting
> process leaves a trail of incremental difference files (at least it
> appears that way). I am currently at a loss as to what to do.
> If anyone knows a trick to try, or how to undo the horrible mistake
> we've made please let me know at camronlent@xxxxxxxxx
> Thanks,
> Camron Lent

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.