[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen + IPv6 + Netapp = NFS read problem


Maybe someone could direct us to right solution with the problem
descibed below. We tried different trick bo no success stories.

We have a development cluster based on Dell R815 servers (+-30) and
a storage server - Netapp FAS 3240 runnig Data Ontap 8.1p2.

We have some 100 virtual servers - we use Xen 4.1 for virtualisation.
A basics OS is Debian Squeeze with some backports packages (newer kernel,
newer xen, newer nfs commons etc)

One of virtual servers is a backup server which has mounted a big nfs
share from Netapp. It copied changed data on Netapp's share (we use
also excellent Netapp's snapshot technology to keep older versions

Our network is mixed 1GBit/10GBit ethernet with junper switch as a central
point of network. Internally we use IPv6 protocol.

The problem is the following:

READ FROM NETAPP SHARE FALLS DOWN TO 5-10MBytes/s !!!!!!!!!!!!!!!!!!!!!!!
On the other hand WRITE PERFORMANCE IS OK i.e 80-100MBytes/s

During test on our testbed system we could read about 250-280 MBytes/s
from our netapp storage (using 10GBit network). The backup server is
connected using 1GBit/s network so we expected some 100MBytes/s performance.

We tried to find a reason of such slow performance and it looks like
it is somewhere between xen bridge and Xen domU and a KEY FACTOR IS IPv6.
 As far as we setup IPv4 connection on Netapp and client regardless
bare metal, dom0 and domU system, all performance (READ/WRITE) is fine.

We made the following tests:

1) Netapp_IPv6 - bare_metal_server_IPv6 - ALL FINE (full network speed)
2) Netapp_IPv6 - Xen_dom0_IPv6_no_bridge - ALL FINE
3) Netapp_IPv6 - Xen_dom0_IPv6_via_bridge - ALL FINE
4) Netapp_IPv6 - Xen_domU-IPv6(via_bridge) - WRITE OK, READ <10MBytes/s !!!!!!
5) Netapp_IPv6 - Xen_domU-IPv6(via_bridge with eth interface
                 set into promiscuous mode) -  WRITE OK, READ 20-25Bytes/s !!!
6) Linux_server_IPv6 (regadless bare metal, dom0 or domU) -
               - Xen_domU-IPv6(via_bridge) - ALL FINE

All mounts use NFS version 3 and proto tcp6.

We checked  MTUs - everywhere 1500. No errors on any side (switch, netapp,
linux clients)... IPv4 connections performs just fine.

ssh/scp and others IPv6 services perform OK ...

Any hints? We think of throwing Xen away :-/

Kind regards,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.