[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Can't get XEN to work at all on Debian 6, 7 and Ubuntu 12.10

Sorry for the late response,

One piece of information that might be useful for further debugging is whether the error occurs when the VM kernel boots or already when the HVM bios boots. You can try this by starting a HVM vm without any virtual disk, thus booting only the HVM bios. Also, it would probably be of interest to know if a PV guest works (you can probably do this easily by starting only a PV kernel, no need to install a full PV system). However, I am not sure on what to do with that information, but someone else might have a clue.
I have tried booting without a virtual disk in the past, that didn't work. However I have not tried a PV guest yet.

@Paul, that's most interested I will give that a go and see what happens.

@Casey, I will take a look at the guide and thank you for the information. It does make me feel a little better ^_^

@Jacek, haven't tried that yet, will give it a go as well.

Also an update:
Which might interest all with a GA-970A or similar chipset motherboard. I got a speedy response from gigabyte as follows:
If you need to enable IOMMU, please update motherboard BIOS to the latest version F12c and then reset "IOMMU support" this BIOS item to Enabled and save BIOS change to test again. 

So it seems that my current BIOS is also a bit dodgy and could be causing me the headache.

So my plans for the weekend are as follows to help shine some light on this:
  • Will re-create Squeeze environment
  • Try a PV guest
  • Will try turning off ballooning
  • Turn off IOMMU support and try HVM / PVM
  • Possibly test the above in Wheezy and Ubuntu 12.10
  • Update BIOS to latest mentioned version as above (F12c is actually a beta candidate, soooo.....)
  • Give it all another whirl
  • If all else fails will try to compile before mentioned versions from source

Will update everyone with findings after I have completed my tests over the weekend. If anyone is really interested in the results (has a GA-970 or similar chipset setup) and I happen to forget, feel free to give me a direct ping and I will try to respond in a timely manner.

Best Regards,
Almir kadric

Website: www.almirkadric.com
Mobile:     +81 90 8008 1578
Office:      +81 03 4550 1448
Email: almir@xxxxxxxxxx

On Mar 19, 2013, at 10:48 AM, jacek burghardt wrote:

Maybe problem is caused by domO ballooning I have this line in grub dom0_mem=1024M,max:1024M loglvl=all guest_loglvl=all and I am using 3.8.3 kernel with opensuse patches and seems to be very stable with 4.3 unstable 

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.