[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Where did I go wrong (creating an HVM guest)?

>I'd recommend either updating to Xen 4.2 (where xl works much better)
>or sticking with xend if you want to use Xen 4.1.

I recently I tried virt-manager with Ubuntu 13.04 and Xen 4.2, and for me, the xl toolstack was a no-go.  On the other hand, xend worked great with virt-manager and Xen 4.2.  So if you want to use virt-manager, either with Xen 4.1 or Xen 4.2, xend is probably still the path of least resistance.

I've gotten virt-manager working in recent releases of Ubuntu by doing the following:

1) $ sudo apt-get install ubuntu-virt-mgmt (includes virt-manager and dependencies)
2) using a terminal, start nautilus as root ($ sudo nautilus)
3) find and open the file /etc/xen/xend-config.sxp
4) uncomment the following lines:
   (xend-unix-server no)
   (xend-unix-path /var/lib/xend/xend-socket)
5) edit the line (xend-unix-server no) to read as
   (xend-unix-server yes) and
6)  save the edited file and reboot.
See https://bugs.launchpad.net/ubuntu/+source/virt-manager/+bug/915954

Also, so that you can successfully start virt-manager as the currently logged in user (not just as root), run the following in a terminal:
$ sudo adduser `id -un` libvirtd

Aside from the need to do all of the above, virt-manager seems to work great.

On Wed, Apr 10, 2013 at 4:58 AM, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:
On Wed, 2013-03-27 at 20:08 +0000, J wrote:
> OK, I'm not "new" to Xen, but it's been a few years (Xen 3.x) since I
> last really messed with it.  I'm now stuck trying to get back into my
> recently installed new guest.
> My host is running Ubuntu 12.04.1 and Xen 4.1 with the xl toolstack.
> I originally created/installed the guest using virt-manager.  The
> install went well and the guest rebooted successfully and I was able
> to access it via
> xl vncviewer guest-name
> Now, the first problem, where's the config file?  Xen 3.x used fairly
> straight forward config files that were stored in /etc/xen/.
> virt-install doesn't create that file.
> I found an sxp format config file in /var/lib/xend/domains/UUID/ that
> matches my guest.  But I'm unable to boot from that.

AIUI virt-manager uses libvirt which is a hypervisor abstraction. The
XML is likely its own format. libvirt can backend onto either xend or xl
(or a variety of other hypervisors).

If you want to continue using virt-manager then I think you will have to
use it completely and not try to mix and match with the lower level
toolstack on a single domain.

> When I try, I get a lot of parser errors and finally complaints about
> it looking like Python code.  So this:
> sudo xl create /var/lib/xend/domains/UUID/config.sxp
> doesn't allow me to reboot the guest.

Right, I wouldn't expect this to work since xl doesn't speak this sxp

> I then tried creating a basic old-style config file:
> builder='hvm'
> name='precise-hvm'
> memory=1024
> maxmemory=1024
> uuid='18069c40-e01f-ddf8-5932-bc6bb6b5bba1'
> vif='xenbr0'

This needs [] around it.

> disk=[ 'file:/vms/precise-hvm.img,qcow2,hda' ]
> I then tried starting the guest there.  That also fails because
> despite what I read here:
> http://xenbits.xen.org/docs/unstable/misc/xl-disk-configuration.txt
> None of these disk lines are accepted by xl:

xl in 4.1 was a bit "tech previewy". I'm not sure when the xl disk
paring stuff was fixed to be properly compatible but I have a feeling it
was post 4.1 (the doc you are referencing at the link above is for

I'd recommend either updating to Xen 4.2 (where xl works much better) or
sticking with xend if you want to use Xen 4.1.


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.