[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Xen not seeing all the memory in the box

  • To: xen-users@xxxxxxxxxxxxx
  • From: Jan Hejl <jh@xxxxxxxxxx>
  • Date: Sat, 13 Apr 2013 10:42:01 +0200
  • Delivery-date: Sat, 13 Apr 2013 08:43:34 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=excello.cz; h=message-id :date:from:mime-version:to:subject:references:in-reply-to :content-type; q=dns; s=default; b=TsHw0myiKJZnwcP8EPHTqZxQbQV+9 UrxAp9h9euWfB7dxVh3TdTf4nhSjrQnTFXt4yta3OicX1G7gWoL5SJObbkZtD/8J Tet9vlDt2G6+gT+xy+p5495gh6QXyJz3PZw
  • List-id: Xen user discussion <xen-users.lists.xen.org>


What does "xl dmesg" says? And how does your grub.cfg look like?

Dne 13.4.2013 01:48, Rich Wales napsal(a):
Replying to Jan Hejl:

Try to add dom0_mem=16G,max:16G to your xen kernel line in GRUB config.
No success.  When I tried this, I couldn't get Xen to start up at all.  It
would say that it was loading the initial ramdisk -- and immediately after
that, the machine would reset and reboot, then do the same thing all over
again, and again, and again . . . .

Eventually, I chose "Ubuntu" from the GRUB screen (which made the system
boot up using ordinary Linux).  I tried editing /etc/default/grub to reduce
the dom0 memory allocation and rebooting -- but the same thing happened
repeatedly, until I finally reduced the dom0 memory to 2560M, at which
point Xen successfully started and I was able to log in.

The "total_memory" value from "xl info" is still 3010 (the same as it was
originally).  So I still can't launch any domU's.

So I still need help convincing Xen to see all 16 GB of RAM in this box.

Rich Wales

Xen-users mailing list

Attachment: smime.p7s
Description: Elektronicky podpis S/MIME

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.