[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Unaible to create DomU Guest

On Tue, 2013-04-30 at 17:15 +0100, Dorian wrote:
> Each reply in bold Char.

I don't see any bold in your reply, because I do not read HTML mail (.
Please stick to the customary ">" style of quoting and post only plain
text mails.

I have gone through and tried to pick out your reply this time.

> > I'm running a new Debian Squeeze release 2.6.32-5-xen-amd64 with
> > minimal components. I've been going through install of Xen as per
> the
> > documentation for the 4.2.1 release and did so by source. However I
> > installed (make install & make world) from
> > within /user/Download/xen4.2.1, I don't know if that is a good/bad
> > idea?
> If you are new to this then I would strongly recommend you use the
> version of Xen which is packaged in Debian. Likewise for the kernel.
> [...]
> I'm not sure what you mean with  "version of Xen which is packaged in
> Debian"

Debian contains binary packages of Xen: 

> when I tried to install with aptitude, I got uncomplete install. From
> source it looks like correct.
> On top... of this I can't google a distro of Debian with Xen included
> (pre-packaged), if that is what you meant. If so please resume with
> this practice.... :

I'm afraid I cannot parse the above. If you are saying that the Debian
packages did not work for you then perhaps this is something to
investigate further. The links I gave above contains various tutorials
regarding installing Xen on Debian.

I really think you would be better off using the binary packages
supplied by Debian.

> > Vif x.x should appear after xm create Virtual-guest.cfg, I guess
> > (which in my case is MArie-DHCP)
> > 
> > root@debian:/home/dorian# brctl show
> > bridge name    bridge id        STP enabled    interfaces
> > pan0        8000.000000000000    no        
> > xenbr0        8000.002655c46159    no        eth0
> Does vifx.y exist in the "ifconfig -a" output?
> This is the second issue I aim to view in sight. I don't see it. I
> have :

On second thoughts this could be because the toolstack cleaned up after
the failure, so we can't really tell anything here.

> > "This problem is often related to udev. Do you have udev installed?
> Is
> > your udev the correct/supported version? "This error usually has
> more
> > information in the end revealing the real reason.. for example:
> > Error: Device 0 (vif) could not be connected. Hotplug scripts not
> working.
> > "This problem is often caused by not having "xen-netback" driver
> > loaded in dom0 kernel.
> > "The hotplug scripts are located in /etc/xen/scripts by default, and
> > are labeled with the prefix vif-*. Those "scripts log
> > to /var/log/xen/xen-hotplug.log, and more detailed information can
> be
> > found there."
> >I  know I installed udev, prior to install xen from source
> > since hotplug plugin doesn't exists/shows up.
> Do you have Xen rules file in /et/udev/rules.d/foo?
> e.g. No file ./foo doesn't exist.

Sorry, foo is usually used as a placeholder for "something".

>  Whereas I have 
> xen-backend.rules
> xend.rules + 3 other beginin 70-... & z60.. 85-pcm..
> # head -n2 /etc/udev/rules.d/xen-backend.rules
> SUBSYSTEM=="xen-backend", KERNEL=="tap*", ENV{UDEV_CALL}="1", RUN
> +="/etc/xen/scripts/blktap $env{ACTION}"
> SUBSYSTEM=="xen-backend", KERNEL=="v...
> ...
> > I've been trying to locate xen-netback driver.
> > root@debian:/dev# cat /proc/modules | grep xen
> > xen_evtchn 4355 1 - Live 0xffffffffa04d7000
> > xenfs 9616 1 - Live 0xffffffffa04ce000
> >>Did you try "modprobe xen-netback" ? Or "find /lib/modules -name
> >>\*netback\*" in case it was called something else in Squeeze?
> A locate xen-netback returns NOthing

The reason I suggested *netback* and not *xen-netback* is the in some
kernels the module is just called "netback" and not "xen-netback", I
don't recall if this is the case for Debian Squeeze or not.

If you use the Debian packages then you won't have this sort of problem
I think.

> These modules come from your kernel, not from Xen itself. The -xen
> flavours of the Debian kernel should have them already (either modular
> or static). If you built your own kernel then you will need to ensure
> you enable the relevant option.
> Is it this you mean that installing xen from source DID NOT install
> these modules. They are present in the Debian kernel?

That is correct. The backend drivers are part of the kernel and not part
of the hypervisor.

> How come I get a FATAL answer! Again you point out the xen flavour of
> Debian kernel... Hm kernel 2.6.32-5 is one ?

No, you need the flavour with -xen in its name. -xen-686-bigmem or
-xen-amd64 IIRC. However if you are already running under Xen and you
don't build your own kernel then you have surely found the correct


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.