[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] Help to boot domU with customized kernel

  • To: Ian Campbell <Ian.Campbell@xxxxxxxxxx>
  • From: Anand Mundada <anandmundada@xxxxxxxxx>
  • Date: Tue, 30 Apr 2013 14:20:20 -0700 (PDT)
  • Cc: xen-users@xxxxxxxxxxxxx
  • Delivery-date: Tue, 30 Apr 2013 23:11:07 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=ymail.com; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:Cc:In-Reply-To:MIME-Version:Content-Type; b=gA0mmx8wLlPgH3p+lRqSEHk6iVJJas+lkrSTwY5gm9OdPSRdVMhLdvidfYtNBh19XoSlRuKz2Lr9Jdcqkn1k/iwwYZc1fVyrIUmQnWVEy88I+wvMBEvGu5iOSduFmlTCgVdN1TyUyh94X9zu0SqoBZ+Sd1ot4WKfMucA5oLd53Y=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

From: Ian Campbell <Ian.Campbell@xxxxxxxxxx>
To: Anand Mundada <anandmundada@xxxxxxxxx>
Cc: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
Sent: Monday, April 29, 2013 3:28 AM
Subject: Re: [Xen-devel] Help to boot domU with customized kernel

On Sat, 2013-04-27 at 16:16 +0100, Anand Mundada wrote:
> Hi All,

This appears to be a user and not development question, xen-users@ is
the appropriate list for such queries. Redirecting (-devel to bcc).

> I have installed Dom0 and domU following instructions given on Ubuntu
> Wiki
> I want to boot domU with customized kernel.

Please give details, version, .config etc. Guest cfg would be useful
also. What version of Xen are you running?

http://wiki.xen.org/wiki/Reporting_Bugs_against_Xen contains a checklist
of information which may be useful to include in a bug report.

> My machine don't have hardware support I tried different things but
> it's not working.
> Method 1:
> In guest, I have compiled Para-Virtualized kernel that have created
> boot images in /boot of domU.
> After reboot I am not able to boot and I am getting error as
> Error: Boot loader didn't return any data

Did you update your bootloader configuration within the guest?

> Method II:
> In dom0, I have compiled Para-Virtualized kernel and I have used
> domU.cfg file where
> kernel= [New compiled vmlinuz]
> ramdisk = [New compiled initrd  image]

How did you create this ramdisk?

> then I tried to create new VM using 'xm create' command.
> Here I am getting following error
> "mount: mounting /sys on /root/sys failed: No such file or directory
> mount: mounting /proc on /root/proc failed: No such file or directory
> Target filesystem doesn't have /sbin/init.
> No init found. Try passing init= bootarg. " 

This indicates that your initrd is not finding the root filesystem. DO
you build in the Xen modules or does your initrd contain the appropriate

> Please let me know to boot domU with new customized kernel?
> Thanks,
> Anand

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.