[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] ERROR: Toolstack not specifed and nothing detected, bailing out!

  • To: "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: Simon Jones <Simon@xxxxxxx>
  • Date: Fri, 3 May 2013 13:44:08 +0000
  • Accept-language: en-GB, en-US
  • Delivery-date: Fri, 03 May 2013 13:45:29 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>
  • Thread-index: Ac5IA4F8B5zecBfgRqSJFojHrFFIOg==
  • Thread-topic: ERROR: Toolstack not specifed and nothing detected, bailing out!

I have just installed Xen by following http://wiki.xen.org/wiki/Xen_Beginners_Guide


All in all pretty good, however it mentions using the xl toolset but when I first installed only the xm toolset would work. This was great for creating linux based domains but it gave me an error about hvm when I tried creating a Windows domain.


I then apt-get install xen-tools-common and edited /etc/default/xen to specify the xl toolset, rebooted and tried again.  This time when doing xl info the system returned:


WARING:  Can't find toolstack xl, fallback to default!

ERROR:  A different toolstack (xm) have been selected!


So I did apt-get remove xen-tools-common and rebooted and set /etc/default/xen to defaults.  Now when I try xl or xm info I get: “ERROR:  Toolstack not specifed and nothing detected, bailing out!”


And I’m stuck, I’ve googled the error but can’t find anything and am not sure what to check now.


Thank you.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.