[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Audio PCI passthrough issues in a Linux domU

Hi everybody,

I recently started playing with Xen on new hardware with VT-D support to set up a "personal cloud". I'm running Xen-4.2.1-r2 with a Gentoo dom0 and have an issue with on-board audio PCI passthrough to a domU.

I'm setting up my first domU with openSUSE 12.3 and half of my CPU cores and memory as a "desktop VM". The USB controller PCI passthrough and secondary GPU passthrough (AMD HD7750) work fine. I also tested Ubuntu 12.04 and 13.04 and they have the same sound issues as openSUSE, and all have good audio on the real hardware.

When I do a PCI passthrough of the onboard 00:1b.0 Intel 7/C210 Series Chipset HD Audio Controller (rev 04), the hardware is available on the domU and detected as snd_hda_intel. Unfortunately, playing sounds results in a lot of skipping, repeating and just generic noise. I tried removing PulseAudio but Alsa also reports "underruns".

Thinking it might be a timing or performance issue, I tried pinning the vcpus, enabling/disabling MSI translation and various sched-credit options to no avail. I also tried various snd_hda_intel settings, which did not really improve the sound quality. I didn't see any interrupt errors on the dom0 or domU.

Has anyone experienced a similar issue? Searching the web and mailing lists showed me that other people mostly had other audio issues (as in simply no sound) with a Windows domU.

I'm looking for suggestions on how to proceed. What logs should I inspect, what settings need checking? Might it be better to use Qemu sound emulation? Should I try XCP instead of my current dom0? Can someone point me towards more documentation about audio passthrough?

Kind regards, Arjen

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.