[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen Reports no IOMMU, but Hardware Supports It

Hello Everyone,

My company is in the process of implementing Xen virtualization. We have managed to get Xen up and running, and have worked through all of the kinks in our set up, except for PCI passthrough. PCI passthrough doesn't work, and I suspect it's because Xen is not using the IOMMU in the computer, even though we built the computer with components that support VT-d.

Here are the computer components we used:
Motherboard: Intel BOXDH77DF
CPU: Intel Core i5-2310 (Sandy Bridge - BX80623I52310)

I also booted Xen up with the "iommu=verbose" parameter and ran "xl dmesg" on the computer, and uploaded the output here: http://pastebin.com/rF0kyftt. I tried running Xen with the "iommu=required" flag, and it failed because it said it couldn't use the IOMMU. If someone work with us to figure out why Xen doesn't use the IOMMU, it would be very appreciated.


Philip Wernersbach
Software Implementation Division
Jacobs Automation
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.