[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Boot Error in converting VMDK/VMX to XEN HVM

  • To: xen-users@xxxxxxxxxxxxx
  • From: Stefan Pielmeier <stefan@xxxxxxxxxxxx>
  • Date: Thu, 30 May 2013 22:57:17 +0200
  • Delivery-date: Thu, 30 May 2013 20:58:56 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>


I am trying to convert a VM Ware Fusion/Player working Virtual Machine with 
Windows XP to XEN.
I recieved some car service manuals in that format and refuse to buy VMWare 
fusion or make VMWare player work on Ubuntu 12.04, this is a nightmare, and I 
have a server for my VM's running XEN, this is just perfect, so why not as well 
for this WinXP VMs with the service manuals on?

I converted the VMDK disk to a physical device using qemu-img convert 
smart.vmdk -O raw /dev/mapper/vol0-domU-smart.

my cfg file for the domU-smart:
vif=[' ']
then I ran "xm create domU-smart"

Trying to boot showed me a: "Booting from Hard Disk..." "Error loading 
operating system_"

Next I tried to repair the MBR and boot sectors:
- win XP bootcd as img and boot from CD works fine, but the XP install was 
protected with a admin password => couldn't start the rescue mode
- then I used trinity rescue to remove the admin password, worked fine, could 
start rescue mode from XP disk :-)
- fixmbr and fixboot got called

Still same boot result: "Booting from Hard Disk..." "Error loading operating 

Then I checked manually the first sector of the harddisk with hexedit and it 
seems ok regarding the partitioning and the position of the boot sector. The 
only strange thing seems that the disk has following fdisk parameters with 56 
sectors/track instead of 63 like in the other examples I found on the net for 
Win XP:

Disk /dev/mapper/vol0-domU--smart: 26.8 GB, 26843545600 bytes
255 heads, 56 sectors/track, 3671 cylinders, total 52428800 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x130b130a

                       Device Boot      Start         End      Blocks   Id  
/dev/mapper/vol0-domU--smart1   *          56    52407599    26203772    7  

could this be some trick to make the VM not working with other than VMWares VM 

Well I am stuck, somebody can help me?
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.