[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] VGA Passthrough of AMD HD8670D IGP to HVM Win7 results in "Code 43"

  • To: Gustav Sorenson <gu.sorenson@xxxxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: David TECHER <davidtecher@xxxxxxxx>
  • Date: Wed, 10 Jul 2013 13:36:12 +0100 (BST)
  • Delivery-date: Wed, 10 Jul 2013 12:37:13 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.fr; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=xkJlyXufPKEVSdMEvUQ7tM8a78Iz24n60Zrygz11vzGg2EF4dNhqjgOsBYH1gEdiv7fWgTXgHCcF9l7r5U96QYVJ1iCOSeeSN8fqqYC+IPgeXIyUTk5VCDJbLlRKfivJszVuguHmkdVT+7rSTrdX707ygM2zKNq+DWnzUbOGYBc= ;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hi Gustav,

I will try not to spam this mailing list :).

Got a HD 7970 and it works both for Win7 (as domU) and Linux (as domU). It works perfectly with 8GB of RAM for domU

Here is a quick summary

- STEP 1) A few Xen features in your kernel are configured as modules (= m) ! I will suggest to set everything directly built in the kernel (= Y) . It is a bit pain to configure the kernel  manually.  My latest test was for kernel 3.8.13. If you can download the kernel and build it yourself that I can sent you my own configuration file for the kernel (3.8.13). After that you will have to update your grub file

- STEP 2) You are testing Xen 4.4 unstable. This branch has to be patched. In Marsh/April the latest patch for ATI has been sent to this mailing list.
So you have to rebuild a patched Xen version (http://www.davidgis.fr/blog/index.php?2013/04/05/937-xen-43-unstable-vga-passthrough-hd-7970-windows-7-64-bits-with-more-than-3gb-for-ram)

- STEP 3) Your configuration file for domU  is not well formed. There are missings options.

I am currently at work for the moment . I will try to share my own configuration file for domU when I am back to home.



De : Gustav Sorenson <gu.sorenson@xxxxxxxxx>
À : xen-users@xxxxxxxxxxxxx
Envoyé le : Mercredi 10 juillet 2013 12h31
Objet : [Xen-users] VGA Passthrough of AMD HD8670D IGP to HVM Win7 results in "Code 43"

Hello everyone,

pardon me If I'm doing anything wrong, this is my first post to this list.

For the past few days, I've been trying to pass the GPU of my AMD A-10 6800K APU to a HVM Windows 7 guest, but haven't had any luck yet.

My relevant hardware is as follows:
AMD A-10 6800K with HD 8670 integrated graphics processor
ASRock FM2A75 Pro4 with latest firmware, so that it (supposedly) supports IOMMU
8GB RAM, 1GB of which has been assigned to the IGP in the BIOS/EFI settings

As you may notice, the IGP is the only graphics device present.

I've tried to follow numerous guides to get VGA passthrough to work; currently, I'm running Linux Mint 13 XFCE and did most of what this guide proposes:

However, with Mint as well as with Debian wheezy, I wasn't able to start DomUs with the xen from the repositories; some seconds after xm create or xl create, the host computer would reboot; I haven't figured out why. The same holds with xen 4.3 compiled from source, at least on Mint. However, the most recent xen from the mercurial repository allows me to start DomUs.
Also, when using Mint, I had to upgrade from the stock 3.2.0-23 kernel to 3.8.0-26 from the backports, otherwise the machine would reset immediately or shortly after xen tried to load the linux kernel. Again, having limited experience with debugging linux or xen problems, I was unable to figure out why.

Finally having installed Windows 7 I installed the most recent AMD catalyst drivers in the DomU. After that, in the Device Manager, the graphics card shows up, but with a yellow triangle; a double click on the GPU gave me "Code 43" as an explanation of what went wrong. What I found with google only points to nVidia-users having that problem.

I also tried to set gfx_passthru to 1, but then xl create would complain:
libxl: error: libxl_dm.c:1275:device_model_spawn_outcome: domain 2 device model: spawn failed (rc=-3)
libxl: error: libxl_create.c:1075:domcreate_devmodel_started: device model did not start: -3
libxl: error: libxl_dm.c:1306:libxl__destroy_device_model: Device Model already exited
and /var/log/xen/qemu-dm-orthowin.log would contain
qemu-system-i386: -gfx_passthru: invalid option

For reference, here is the kernel config: http://pastebin.com/kwUWkyP2
My DomU configuration: http://pastebin.com/E9jkkJXj
The output of xl info: http://pastebin.com/nj1ykFXJ
The output of xl dmesg: http://pastebin.com/MS96knmL
The output of dmesg: http://pastebin.com/2sQFuCuJ
Please note, as it might be related to my issue, that what comes at the end of the dmesg output seems suspicious to me (RIP  [<ffffffff81012861>] xen_spin_lock+0x21/0x50 and the lines around that)

I hope that I have provided enough information for further investigation. The computer is not in any kind of production-use, so please feel free to request things that will or may require me to reinstall the operating system or some of its components. As the hardware is new, I'd not be happy if I had to do something that would risk permanent damage. :)
Should this be the wrong mailing list for this kind of post, please let me know where I can send it to instead.

Thank you very much for your time, any help is highly appreciated, not only regarding my primary problem (getting VGA passthrough to work) but also the others mentioned, especially since they might be related.

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.