[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Xen-devel] [BUG REPORT] My Xen 4.3-unstable Changeset 26666 Installation is Broken!

On 07/27/2013 10:52 AM, Singapore Citizen Mr. Teo En Ming (Zhang Enming) wrote:
On 27/07/2013 17:49, Singapore Citizen Mr. Teo En Ming (Zhang Enming)
On 26/07/2013 16:52, Ren, Yongjie wrote:
-----Original Message-----
From: Singapore Citizen Mr. Teo En Ming (Zhang Enming)
Sent: Friday, July 26, 2013 4:39 PM
To: xen-devel@xxxxxxxxxxxxx; Teo En Ming (Zhang Enming); Ian Campbell;
Konrad Rzeszutek Wilk; Ren, Yongjie
Subject: [BUG REPORT] My Xen 4.3-unstable Changeset 26666 Installation
is Broken!


My Xen 4.3-unstable changeset 26666 installation is broken. The
following is my bug report.

teo-en-ming@intel-core-i5-4430-desktop:~$ sudo xl create
Parsing config from /etc/xen/windows7
failed to free memory for the domain

teo-en-ming@intel-core-i5-4430-desktop:~$ sudo xl list
libxl: error: libxl.c:557:libxl_list_domain: geting domain info list:
Permission denied
libxl_domain_infolist failed.

teo-en-ming@intel-core-i5-4430-desktop:~$ sudo xl dmesg
libxl: error: libxl.c:4759:libxl_xen_console_read_line: reading console
ring buffer: Permission denied

teo-en-ming@intel-core-i5-4430-desktop:~$ sudo xl info
host                   : intel-core-i5-4430-desktop
release                : 3.10.0-xen-teo.en.ming-sgp
version                : #1 SMP Sat Jul 13 00:07:55 SGT 2013
machine                : x86_64
libxl: error: libxl.c:3938:libxl_get_physinfo: getting physinfo:
Permission denied
libxl_physinfo failed.
libxl: error: libxl.c:4320:libxl_get_scheduler: getting domain info
list: Permission denied
xen_major              : 4
xen_minor              : 3
xen_extra              : -unstable
xen_version            : 4.3-unstable
xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p
hvm-3.0-x86_32p hvm-3.0-x86_64
xen_scheduler          : (null)
xen_pagesize           : 4096
platform_params        : virt_start=0xffff800000000000
xen_changeset          : Thu Feb 28 09:22:41 2013 +0100
xen_commandline        :
cc_compiler            : gcc (Ubuntu/Linaro 4.7.3-1ubuntu1) 4.7.3
cc_compile_by          : root
cc_compile_domain      :
cc_compile_date        : Thu Jul 25 23:20:43 SGT 2013
xend_config_format     : 4

Please let me know how to solve this bug.

I don't know how to resolve it.
But if you want to do IGD passthrough, you can try with Xen 4.3.0
release with latest traditional qemu.
It can also successful for me with Xen 4.3.0 release with latest
traditional qemu.

Best Regards,
      Yongjie (Jay)

Thank you very much.

Yours sincerely,

Singapore Citizen Mr. Teo En Ming (Zhang Enming)

Hi Yongjie,

I tried to use Xen 4.3.0 official release and Linux kernel 3.8.1 but
IGD passthrough is still unsuccessful. Yellow triangle with
exclamation mark and error code 43 still show up in Device Manager for
Intel HD Graphics 4600.

I have attached my configuration files. What else can I do?

I have also filed a bug for Xen 4.3-unstable changeset 26666 at

Hi All,

Please check through my configuration files to see if there is any error
or mistake.

Thank you very much.

Have you tried a vBAR=pBAR patch?

See here for more details:


This is mainly aimed at Nvidia GeForce cards (GeForce drivers don't handle the case where vBAR != pBAR, but Quadro drivers do - I modified my GeForce cards to equivalent Quadros to work around the issue). But - it may also help with your situation. It is entirely plausible that your GPU is having problems finding some of it's BARs, which might also explain why it is stuck in a low resolution / 4-bit colour mode.

I am not sure how much you might need to adapt this and which patches you can skip or will have to modify for IGD instead of GeForce, but it's probably worth a shot.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.