[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] question regarding booting custom guest kernel

I gave the answers inline. Here they are, again inline -

On 27 September 2013 16:16, Wei Liu <wei.liu2@xxxxxxxxxx> wrote:
On Fri, Sep 27, 2013 at 04:05:55PM +0200, Aastha Mehta wrote:
> >
> > Wei.
> >
> No, it is not an intermitten failure, because I have another guest image
> that I am able to boot fine.

What I meant is the debootstrap failure was due to intermittent failure
of network. Did you check that? Did you run the same rune multiple times
to rule that out?

If it is not due to network failure, you need to check the delta between
your runes and figure out why one worked but the other didn't.
The differences are in the sizes provided for Swap, Disk, RAM. Additionally, I included flags like --keep, --install=1, --boot=1 in the case of the modified kernel.

> I also tried to replace the kernel in the image that I created from the
> mirror. But I am seeing the networking error about the vif being not set up
> correctly. Any idea, why that might be happening and how to fix it?

You didn't answer my questions in first mail. How did you install Xen?
Do you have hotplug scripts in /etc/xen?
Xen (4.4-unstable) is also custom built. I have following hotplug scripts in /etc/xen/scripts:

Does it boot fine with original kernel?
I added the following line in the config file for original kernel:
bootloader   = '/usr/local/lib/xen/bin/pygrub'
Everything else was the default generated -

When I did xl create, I got the following error:
Parsing config from /etc/xen/precise-guest.cfg
libxl: error: libxl_bootloader.c:628:bootloader_finished: bootloader failed - consult logfile /var/log/xen/bootloader.17.log
libxl: error: libxl_exec.c:118:libxl_report_child_exitstatus: bootloader [31933] exited with error status 1
libxl: error: libxl_create.c:900:domcreate_rebuild_done: cannot (re-)build domain: -3

And the log file says:
File "/usr/local/lib/xen/bin/pygrub", line 885, in <module>
raise RuntimeError, "Unable to find partition containing kernel"

Do you have necessary netfront module enabled in you modified
kernel? What did you modify?
I do have the netfront module enabled in the modified kernel. I added a null system call which calls to a null hypercall (added in the Xen).

Below is the content of the guest1 config file:
kernel     = '/boot/vmlinuz-3.11.0-guest'
ramdisk  = '/boot/initrd-3.11.0-guest'
vcpus     = '1'
memory = '2048'
root       = '/dev/xvda2 ro'
disk      = [
name    = 'ubuntu-3.11.0-guest1'
dhcp     = 'dhcp'
vif         = [ 'mac=00:16:35:46:82:E4' ]



> Thanks
> --
> Aastha Mehta
> MPI-SWS, Germany
> E-mail: aasthakm@xxxxxxxxxxx <aasthakm@xxxxxxxxx>

Thanks for your time.

Aastha Mehta
MPI-SWS, Germany
E-mail: aasthakm@xxxxxxxxxxx

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.