[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Install Xen 4.4-Unstable

On 10/26/2013 01:51 AM, Ian Campbell wrote:
On Fri, 2013-10-25 at 20:49 -0500, John Wargo wrote:

[root@Hypervisor /]# find -name "libxlutil*"
You appear to have two parallel installations of Xen here, one with
prefix=/usr and one with prefix=/usr/local. Have you tried invoking
configure with a variety of options at some point?

Having two installs could be causing all sorts of confusion, and will
certainly trip you up in the future. You should clean one of them up
("make uninstall" in a tree ./configure'd however you did it initially
would be a good start).

[root@Hypervisor /]# which xl
/usr/bin/which: no xl in (/usr/lib64/ccache:/sbin:/bin:/usr/sbin:/usr/bin)
This suggests that the installation in prefix=/usr is somehow incomplete
(or else xl would be in /usr/sbin/xl) so that is probably the one to get
rid of.

If you are going to use prefix=/usr/local (which is a good idea to keep
installed from source stuff separate to package managed stuff) then it
seems like your distro requires you to add /usr/local/{sbin,bin} to your
$PATH manually.

However this result also conflicts with the log you posted previously
for the output of "ldd `which xl`" where obviously an xl must have been
found. Do you have only a single system you are experimenting with or
could that result have been a different one? Maybe you just forgot to
amend your $PATH in this case?



Sorry for the confusion, I have tried with a variety of configuration options, and the "ldd `which xl`" came from before that. My plan is to clean up all of the installs, then just have it installed to /usr/local/bin (or sbin if necessary). I will post here when I am done, and if it doesn't work, then I'll post the correct ldd, which, and find.

Again, sorry for your confusion,

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.