[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Live Migration between different CPUs, cpuid

On 10/30/2013 9:00 AM, Michael Fischer wrote:
On 10/29/2013 09:23 PM, James Pifer wrote:
On 10/29/2013 10:47 AM, Michael Fischer wrote:
I'm trying to accomplish live migration between two dom0s with different CPUs (Intel(R) Xeon(R) CPU E5-2430 and Intel(R) Xeon(R) CPU E5620).
As indicated here (http://zhigang.org/wiki/XenCPUID) you can mask cpu features for domUs with the cpuid directive. But I don't seem to get my directives right - to be frank I don't know how to interpret the following output of cpuid:
Can anybody point out to me what I should set as cpuid=[ '' ] in my domU config?
Thanks in advance, Mike


You can try the cpuid codes that work in most cases for us. It was a lot of work to get to these, with the help of our vendor. I kind of understand some of it, but not all of it.

I like having them in different formats like this so it's easy to determine which one I'm using. (full vs para virt)


For PV VMs:

I don't have one working for Windows 2012 yet.

Also, not sure what flavor of xen you're running, but we use SLES11/xen and had to have some xen patches for this to work for us. Before the patches, it would start to migrate and you could see it paused on the destination, but then it would disappear.

Hi James!

Does not seem to work for me :-( I'm still getting the following error:
"Couldn't set eXtended States for vcpu0 (22 = Invalid argument): Internal error" (full log attached)

We are running SLES11/xen (SLES11 SP3), kernel 3.0.82-0.7-xen #1 SMP, xen version 4.2.2_06-0.7.1 (abuild@) (gcc (SUSE Linux) 4.3.4 [gcc-4_3-branch revision 152973])

I should also mention that if the domU has been started on the E5620 (the older CPU) migration works fine. But migrating back crashes the machine with the above error.

My guests are pv - in this case sles11 sp3 with oes - I haven't tried hvm guests yet.

Any more ideas?


I had the same situation. I could migrate to the newer CPU, but not backwards.

I believe that is where the patch comes into play. Last night I applied the wrong patch (earlier PTF attempt) on one of my servers and I believe I had that exact error. Applied the correct PTFs and then it worked as expected.

I'm still using the PTF version of the RPMs as the patch has not made it into the SP2 channel yet. I do not know whether the patch will be automatically checked/applied to SP3, but I assume so.

If you have support with Novell you may want to open a ticket. You may be able to get a PTF.

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.