[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Requesting Help - Error: pci: PCI Backend and pci-stub don't own device

On Tue, 2014-02-04 at 12:48 -0500, Mike Neiderhauser wrote:
> Hi all,
> I am new to Xen and hyper vision in general.  I have been searching
> the mailing list and using my friend google to see if I could find the
> answer myself.  Unfortunately, everything I have tried and found does
> not work.
> I am attempting to set up a Computer with two HVM's.  To start, I
> attempted it with a single HVM.  I am able to install, configure,
> start, and VNC into the VM.  The issue is when I attempt PCI pass
> through.  I have tried attaching the pcie switch as well as individual
> pci devices.  I am trying to attach an Intel 82576 Gigabit Ethernet
> card to the HVM.  I am unsure of what information you will need, but
> included is information I felt was useful.  I have tried various PCI
> configs in the .cfg file.  From the information that I can see, the
> pci devices do appear to be mapping to the pciback driver.
> Any help with this would be greatly appreciated!

By eye it all looks quite reasonable to me.

The current configs are passing through the PCI switch in various
combinations with the devices which is most likely not what you want,
normally you should only pass the devices themselves I think (TBH I'm
not sure what happens if you pass a bridge too...).

Have you tried just passing through 05:00.0 (one of the NICs) or just
05:00.0 and .1?

What does "xm pci-list-assignable-devices" report?

What is the actual failure more? Simply not seeing the device in lspci
within the guest or seeing it but it doesn't work or ...?

Please can you post the guest dmesg with just a NIC passed through.

You might also find some information in the logs under /var/log/xen,
especially the device model log.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.