[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] Xen on ARM on the ODROID-XU

Hi all,
I'm trying to get Xen 4.4 running on my ODROID-XU device but I got stuck. I followed the Wiki and built a 3.13 kernel with the necessary xen options enabled and verified that it boots by itself. I built Xen from git and created a u-boot image as follows:

 mkimage -A arm -T kernel -a 0x40008000 -e 0x40008000 -C none -d "./xen/xen" xen-uImage

I tried a variety of u-boot configuration options found on the Wiki and the mailinglist, however, nothing seems to be working. The Wiki is not very consistent about the u-boot options either. This is the last config i tried, but nothing made a difference so far. I get no output on the console after u-boot.

setenv initrd_high "0xffffffff"
setenv fdt_high "0xffffffff"
setenv xen_addr_r 0x42000000
setenv dtb_addr_r 0x46000000
setenv kernel_addr_r 0x49000000
setenv ramdisk_addr_r 0x60000000
setenv xen_path /xen-uImage
setenv dtb_path /exynos5410-odroidxu.dtb
setenv kernel_path /uImage-xen-dom0
setenv ramdisk_path /uInitrd-xen-dom0

setenv bootargs 'sync_console console=tty1 console=ttySAC2,115200n8'
setenv dom0_bootargs "${bootrootfs} ${fb_control} fb_x_res=${fb_x_res} fb_y_res=${fb_y_res} vout=${vout} hdmi_phy_res=${hdmi_phy_res} led_blink=${led_blink}"

fatload mmc 0:1 ${dtb_addr_r} ${dtb_path};
fatload mmc 0:1 ${xen_addr_r} ${xen_path};

# When is this required?
fdt addr ${dtb_addr_r}
fdt resize

# What do these options do? Are these specific to the device or Xen or ..?
fdt set /chosen \#address-cells <1>
fdt set /chosen \#size-cells <1>

fdt mknod /chosen module@0

fatload mmc 0:1 ${kernel_addr_r} ${kernel_path};

# What is linux-zimage? My images are not in zImage format, does that matter?
fdt set /chosen/module@0 compatible "xen,linux-zimage" "xen,multiboot-module"
fdt set /chosen/module@0 reg <${kernel_addr_r} 0x${filesize} >
fdt set /chosen/module@0 bootargs "${dom0_bootargs}"

fatload mmc 0:1 ${ramdisk_addr_r} ${ramdisk_path};

setenv bootcmd "bootm ${xen_addr_r} ${ramdisk_addr_r}:${filesize} ${dtb_addr_r}"

The output is:

## Booting kernel from Legacy Image at 42000000 ...
   Image Name:
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    656144 Bytes = 640.8 KiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... OK

## Loading init Ramdisk from Legacy Image at 60000000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (uncompressed)
   Data Size:    1840391 Bytes = 1.8 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK

## Flattened Device Tree blob at 46000000
   Booting using the fdt blob at 0x46000000
   Loading Kernel Image ... OK


   Using Device Tree in place at 46000000, end 460098c0

Starting kernel ...

No output after that.

I'm a newbie to the ARM world and spent the last couple days reading everything related that I could get my hands on. Some help would be much appreciated!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.