[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] pv-grub installation problem

On 31 March 2014 13:53, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:
> On Mon, 2014-03-31 at 13:44 +0200, Aastha Mehta wrote:
>> I tried few grub commands, but it doesn't find any of the files,
>> devices, anything. What you hinted at may be true - that the config
>> file is not being read at all. I will investigate from that point.
> I just booted and at the grubdom prompt tried the "menu (hd" command and
> tab, which said:
>         grubdom> root (hd
>          Possible disks are:  hd0 hd1
> so I tried hd0:
>         grubdom> root (hd0)
>          Filesystem type unknown, using whole disk
> No good. So I tried hd1:
>         grubdom> root (hd1)
>          Filesystem type is ext2fs, using whole disk
> This is using
>         disk        = [
> 'phy:/dev/cam-st16/debian.guest.osstest-disk,xvda2,w',
> 'phy:/dev/cam-st16/debian.guest.osstest-swap,xvda1,w',
>                       ]
> I think what has happened is that xvda1 => hd0 and xvda2 => hd1.
> My guest is setup for booting from a dom0 kernel, so my /boot is empty,
> so I can't go much further, but perhaps this will help you make
> progress.
> Ian.

Wow, I didn't think of trying that. And indeed it works!

Thanks a lot!


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.