[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] AMD cards - VGA passthrough no more possible with newer Xen / kernel releases

  • To: Gordan Bobic <gordan@xxxxxxxxxx>, "xen-users@xxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxx>
  • From: "H. Sieger" <powerhouse.linux@xxxxxxxxx>
  • Date: Thu, 10 Apr 2014 00:57:45 -0700 (PDT)
  • Delivery-date: Thu, 10 Apr 2014 07:58:27 +0000
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=X-YMail-OSG:Received:X-Rocket-MIMEInfo:X-Mailer:References:Message-ID:Date:From:Reply-To:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=4log0DLSxT1aDVJFKBteAu4iNq6XtBcY7PZFGy5fBZ585TkrZ3h9zWf1fzGRIntaJLMP84QUNMSQNEedxcyxX0+WlKROiD1O3tC0D6LcXLh7Xw6BO9Mjw7swxCyIpcC6LDwpJgszKRo+DZ2KN8Ev37nsHk12P4lJIcwPB4UPTQc=;
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Thanks Gordan. I'm using the run-off-the-mill kernels and Xen hypervisors provided by the Ubuntu/Linux Mint repositories and haven't yet dug into compiling the stuff. My goal is to provide an easy way to VGA passthrough, and compiling Xen might well defeat that goal. That said, if anyone knows about a more recent kernel/Xen combination that works with AMD cards I would like to try that.

My tests so far show that there isn't any issue with AMD graphics cards passthrough when you use the xm toolstack with kernel 3.2.0-22 (the original kernel used in Ubuntu 12.04) and Xen 4.1.2 (again, the original version that comes with the ISO image). With the xm toolstack you can also reboot the guest as often as you like without any side effects or dom0 crashes/performance loss/etc.

Once I upgrade either the kernel, or Xen, or both, things go sour. The xm toolstack gives error 22, no matter which Xen release I use (that is both Xen 4.1.3 and 4.3 give me the same error 22). With Xen 4.1.3 this is expected behaviour, as the bug introduced by an XSA wasn't fixed yet. But Xen 4.3 does have the bug fix (I checked it) and still it produces error 22 invalid ....

Similarly, when I run Ubuntu 12.04 / Linux Mint 13 with a 3.2 kernel and upgrade the kernel from the original version to a newer one, specifically to the latest 3.2.0...-60 kernel, I also get the error 22.

The xl toolstack displays other issues, starting from libxl errors that prevent starting the domU to the infamous dom0 crash upon domU shutdown. In my case, if and when I get xl start the domU, every shutdown of the domU requires me to hard reset the PC. Back in dom0 things look OK, but a restart of the domU is not possible. I also cannot shutdown the dom0 - it would just hang until I press the hard reset button.

I've ran bootchart to check when pciback kicks in and from what I can tell is that loading it from initramfs puts it before the graphics driver. See here (this was done with a AMD 7770 and fglrx for dom0 and Quadro 2000 for domU).

To me it looks like somewhere along the line changes introduced into the kernel and/or Xen break VGA passthrough with AMD cards. In contrast, my Nvidia Quadro 2000 works both with Xen 4.1.2 and 4.3 with the xm toolstack, as well with 4.3 with the xl toolstack without issues. It does, as expected, give the error 22 with Xen 4.1.3. since that release still had the bug.

If I find the time I will test Xen 4.4 and see what it does.
On Wednesday, April 9, 2014 2:59 PM, Gordan Bobic <gordan@xxxxxxxxxx> wrote:
On 2014-04-09 08:36, H. Sieger wrote:

> Does anyone here have a solution? It can't be that AMD users have to
> use ancient kernel and Xen releases with a deprecated xm toolstack to
> enjoy VGA passthrough.

FWIW, I've never managed to get ATI cards to reliably handle domU
reboots gracefully, regardless of the Xen and kernel versions used.
They work fine on the first domU boot, but in practically all cases
if you need to reboot domU you have to reboot the whole host.

Most recently I tried this with a 7970 on Xen 4.3.0 with Kernel 3.9.9
and that is the result I saw.

AMD are also too quick to abandon old products and OS-es. HD4xxx
series is essentially abandoned, as is XP for the R9 290X cards.
In contrast, Nvidia's drivers still support XP and cards going
back to their 8xxx series cards.

> P.S.: I would file bug reports but it seems pointless, there are just
> too many things going wrong. The error 22 with xm should have been
> solved long ago, and yes, I checked the python code and the bug fix
> has been applied in Xen 4.3.0, yet there is again the infamous error
> 22 message.

It might be worth double-checking that you updated the entire stack,
hypervisor and userspace. When I had this problem that didn't go
away after the patch, it turned out to be because I had some stale
leftovers from the previous installation.

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.