[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Fwd: xc_dom_kernel_file failed: No such file or directory

On Fri, Apr 18, 2014 at 06:01:40PM +0100, Ian Campbell wrote:
> On Fri, 2014-04-18 at 13:55 -0300, Facu Curti wrote:
> > I tried to give mode +x to /usr/lib/xen/bin/qemu-dm, but it doesn't
> > exist. Maybe I have a missed package?
> You haven't given any details about your dom0 distro, how you installed
> Xen, nor what version of Xen you are running, so it is very hard to give
> any advice.
> Ian.

Solved! :). You was rigth. I'm using gentoo:

uname -a:
Linux facGentoo 3.12.13-gentoo #21 SMP PREEMPT Tue Apr 15 08:57:05 ART 2014 
x86_64 Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz GenuineIntel GNU/Linux

I had emerged xen-tools without qemu flag. Before:

emerge -pva xen-tools:

[ebuild   R    ] app-emulation/xen-tools-4.3.1-r5  USE="pam -qemu -api 
-custom-cflags -debug -doc -flask -hvm (-ocaml) -pygrub -python -screen 
-static-libs -xend" PYTHON_SINGLE_TARGET="python2_7 -python2_6" 
PYTHON_TARGETS="python2_7 -python2_6" 21,972 kB 


[ebuild   R    ] app-emulation/xen-tools-4.3.1-r5  USE="pam qemu -api 
-custom-cflags -debug -doc -flask -hvm (-ocaml) -pygrub -python -screen 
-static-libs -xend" PYTHON_SINGLE_TARGET="python2_7 -python2_6" 
PYTHON_TARGETS="python2_7 -python2_6" 21,972 kB 

So, it is solved. But now I have another problem ._. This will end
sometime? lol.

libxl: error: libxl_device.c:894:device_backend_callback: unable to add device 
with path /local/domain/0/backend/vif/11/0
libxl: error: libxl_create.c:1115:domcreate_attach_vtpms: unable to add nic 
libxl: error: libxl_device.c:894:device_backend_callback: unable to remove 
device with path /local/domain/0/backend/vif/11/0
libxl: error: libxl.c:1452:devices_destroy_cb: libxl__devices_destroy failed 
for 11

Thank you men!

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.