[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] ucode=-1: did anybody have success?


did anybody use Xen's ucode option successfully?
I'm trying to update the microcode before dom0 starts, since my dom0
doesn't have the xen microcode driver. I'm using a vanilla 3.12.x kernel
from kernel.org and to the best of my knowledge, the xen microcode
kernel driver didn't make it upstream yet, i.e., it's only in konrad's tree.

So I probably want ucode=-1. The documentation is speaking of a CPU
microcode update BLOB. So all I need is to make the microcode BLOB the
last module in grub, right? But: BLOB in which format?

Well, on my system the microcode exists in two formats:
- /lib/firmware/microcode.dat (not sure what the format is, it's
definitely not cpio based, as would be needed for ucode=scan)
- many single files in /lib/firmware/intel-ucode/

Which line in grub would be correct? I guess it isn't
  module /lib/firmware/microcode.dat
  module /lib/firmware/intel-ucode/<somefile>
by any chance?

Now the documentation of ucode goes one to talk to about some file
called kernel/x86/microcode/GenuineIntel.bin. But it only talks about it
in combination with ucode=scan. A wild guess could be, that this file is
identical to microcode.dat. Another wild guess could be, that this file
is something I have to download from intel, and this is also the file I
have to use as a module in case I'm using ucode=-1 instead of ucode=-1.

So could somebody who did all the research and experimenting show his
working configuration to me?

I think I tried microcode.dat once, and it didn't seem to work.
I haven't tried a file from /lib/firmware/intel-ucode/ as I only have
one production system and my test system is a VM where microcode updates
are not possible.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.