[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Question about the USB Passthrough in Xen

Hi Alexandre,

Thank you so much for your reply!

âAfter I use `xl create dom1.cfg`, Âno /dev/input/js0 was created in the
guest domain 1.
(I have the /dev/input/js0 in dom0.)
(I also tried to use usbdevice=['tablet','host:1.8','host:046d:c21f'] as
shown in xen's website and still couldn't see /dev/input/js0 in guest
domain 1.)
What does lsusb in the guest domain says, after you attach the USB device to it?

âIt reports errors:
unable to initialize libusb: -99
â(I have libusb-1.0-0-dev installed using apt-get)

I googled around but couldn't find the reason why it returns -99. I'm guessing it's because domU does not know the usb device?

Have you tried to hot-plug it instead of specifying in the config file?

âNo. I'm trying to switch to xm, but it has problems. I'm curious if usb hot-plug is the only way to use the USB in the guest domain? Since the xm is depreciated in the current branch and xl usb hotplug won't appear until the release of âxen 4.5. Maybe configuring it in the configuration file of guest domain is better?

Thank you so much for your time and help!





Alexandre Kouznetsov

Xen-users mailing list


Meng Xu
PhD Student in Computer and Information Science
University of Pennsylvania
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.