[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] [Solved] (pv)hvm, upstream qemu 1.7.1

On 05/14/14 10:05, Sylvain Munaut wrote:
> Interestingly I had the same "MMIO emulation" issue when trying to
> build xen-4.4 package for debian wheezy (based on the xen 4.3 package
> for jessie).
> But in that case, it was kind of the opposite, I was trying to use the
> system seabios and etherboot (like in xen 4.3 debian package), but
> this caused the compiled hvmloader to be broken. By letting the xen
> build use its own seabios and etherboot to build hvmloader, it then
> worked fine. And then I'm using the distribution provided qemu 2.0
> (which should be using the system seabios if it needs one).

There is a difference in the BIOS binaries used by qemu.

qemu 1.7.1 provides a single, 256kB seabios image in the 'bios.bin'
file.  qemu 2.0.0 provides two seabios images: a stripped one 128kB
'bios.bin' and another one: 256kB 'bios-256k.bin'.

I guess that older qemu version could use only a 128kB 'bios.bin' image.

I am not sure what is the seabios image included in the Xen build by
default, but if it is 128k, then this could explain the differences.

Of course, 'the system seabios' may be very distribution-specific and
different from what upstream qemu or Xen provide.


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.