[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] maxvcpus entry in cfg -> Error: unsupported operand type(s) for <<: 'int' and 'str'

Hi folks,

we run some xen servers on different OS versions (debian 6, debian 7 and
Ubuntu 12.04) but didn't have the "maxvcpus" entry in the config files
for our virtual machines until now.

Today I wanted to add it to the .cfg files for some domUs and tested it
with one machine I could shutdown and recreate to test the change of
amount of vcpus for this machine while it is running.

Unfortunately, while "creating" the VM, I got the following error and
the VM refused to start:

  Error: unsupported operand type(s) for <<: 'int' and 'str'

I tried some different writings for the maxvcpus line entry but got the
same error evrey time untill I commented the line.

Then the machine was created again.

I tried the following writings:
maxvcpus = 4
maxvcpus ='4'
maxvcpus = 4;

The test-vmserver has:
 * Debian GNU/Linux 6.0
 * Python Version: 2.6.6-3+squeeze7
 * xen-hypervisor-4.0-amd64 4.0.1-5.11
 * xen-tools 4.2-1
 * xen-utils-4.0 4.0.1-5.11

Many thanks in advance for every hint how to solve this problem.

Yours Henri

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.