[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Blank screen in EFI mode but XEN seems to work

Hi all,

I have a similar issue like this one. I hope you guys can help me sort it out.

My system is gentoo with UEFI, and my partition layout is:

EFI partition/
  grubx64.efi # for grub
/ # root for the rest of my system

I ran "efibootmgr -c -l 'gentoo\xen-4.4.1.efi' -L Xen" and reboot the system. During the boot, the screen display something I think is related to Xen, then it turns blank, no disk activity at all. Looks like halted.

My xen.cfg looks like this:


kernel=kernel-gentoo root=....
# i am not using an initramfs file


On Mon, Feb 24, 2014 at 9:00 PM, Ian Campbell <Ian.Campbell@xxxxxxxxxx> wrote:
On Thu, 2014-02-20 at 22:24 +0100, Michael Rack wrote:
> I did so.
> Self requote: "When booting from >> xen.efi << i get instantly a blank
> screen, but the XEN Hypervisor boots and i am able to SSH into it.
> Also i am able to issue commands in "blind mode"."

Sorry, my mistake, I saw the mention of grub in the next para and my
pattern matching system went off ;-)

> I don't know what was the solution, but now it works.


> I formated my boot-partition to start a fresh EFI-installation.
> I installed GRUB-EFI and XEN.EFI and told the EFI-Firmware the positions.
> After rebooting, and selecting the XEN-KERNEL via the EFI-Boot-Manger,
> XEN-Hypervisor-Kernel and Linux-Kernel booted and the screen went not blank.
> Perfekt. Thanks.
> Liebe GrÃÃe aus Freilassing,
> Michael Rack
> RSM Freilassing

Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.