[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] shared lib path errors


As part of a dev activity, I built Xen 4.5.0 from source and installed it successfully on my Ubuntu 14.04 server, However I am getting this error when running "xl list":

xl: error while loading shared libraries: libxlutil.so.4.3: cannot open shared object file: No such file or directory

Based on some archived threads, I verified the following.
--> This soft link & file exist in /usr/local/lib:Â libxlutil.so.4.3 -> libxlutil.so.4.3.0
--> /etc/ld.so.conf has this line: "include /etc/ld.so.conf.d/*.conf"
--> /etc/ld.so.conf.d/libc.conf has this content:
line 1: # libc default configuration
line 2: /usr/local/lib

Based on archived threads, xl should be searching /usr/local/lib based on the above. But it is obviously not. Meanwhile I tried linking the /usr/local/lib copy to /usr/lib. That worked (but now it's complaining similarly about not finding libxenlight). Not sure it matters but one final detail: echo $LD_LIBRARY_PATH from my shell shows nothing.

Are there any solutions recommended other than putting soft links in /usr/lib?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.