[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Compliling Xen 4.5.0 Fails

On Fri, 2015-03-13 at 11:46 +0000, Ian Murray wrote:
> Hi,
> I get an error when trying to compile Xen 4.5.0 from source. It
> happens from the tarball and also from Git. I have tried it on two
> boxes with the same result (Ubuntu 12.04.5). I can compile 4.5.0-rc4
> with no problems. I haven't looked at the differences in Git yet...
> was just curious if anyone else had had the same issue.

I've not heard any one else mention it, which does seem odd. Do you set
any interesting CFLAGS or anything when you build Xen?

"-no-nused-but-set-variable" isn't a real option AFAIK, but I suppose it
is mostly likely a cut-and-paste error (dropped a "u") not something
you've got in your build environment.

> Any suggestions?

Looking at the code I think the compiler is just not smart enough to
realise that the variable is always initialised. Or at least I'm
struggling to find a path where it isn't... But the control flow in that
function is pretty complex so I'd not be surprised of both gcc and
myself were flumoxed ;-)

Unless you are passing strange options to the build process then I think
you should take this to the -devel list so the authors of the code can
a) see if they can spot something I can't and b) consider if they can
rewrite it a bit to unconfuse the compiler.

> Apologies if this appears twice. I used an old list address to start with.

FWIW mails to xen-*@lists.{xen.org,xenproject.org,xensource.com} all get
routed to the appropriate list in the end.

This copy had the benefit of not being in HTML though.


> make[5]: Entering directory `/root/xen450/xen-4.5.0/xen/arch/x86/hvm'
> gcc -O2 -fomit-frame-pointer -m64 -fno-strict-aliasing -std=gnu99 -Wall 
> -Wstrict-prototypes -Wdeclaration-after-statement -no-nused-but-set-variable  
>  -DNDEBUG -I/root/xen450/xen-4.5.0/xen/include  
> -I/root/xen450/xen-4.5.0/xen/include/asm-x86/mach-eneric 
> -I/root/xen450/xen-4.5.0/xen/include/asm-x86/mach-default -msoft-float 
> -fno-stack-protector -fno-exceptions -Wnested-xterns -DHAVE_GAS_VMX 
> -DHAVE_GAS_EPT -DHAVE_GAS_FSGSBASE -mno-red-zone -mno-sse -fpic 
> -fno-asynchronous-unwind-tables -GCC_HAS_VISIBILITY_ATTRIBUTE -fno-builtin 
> -fno-common -Werror -Wredundant-decls -Wno-pointer-arith -pipe -g -D__XEN__ 
> -include root/xen450/xen-4.5.0/xen/include/xen/config.h -nostdinc -DHAS_ACPI 
> hvm.c -o hvm.o
> hvm.c: In function âhvm_create_ioreq_serverâ:
> hvm.c:487:18: error: âbufioreq_pfnâ may be used uninitialised in this 
> function [-Werror=uninitialized]
> hvm.c:718:30: note: âbufioreq_pfnâ was declared here
> cc1: all warnings being treated as errors
> make[5]: *** [hvm.o] Error 1
> _______________________________________________
> Xen-users mailing list
> Xen-users@xxxxxxxxxxxxx
> http://lists.xen.org/xen-users

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.