[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] xenpvnetboot failed with message "no space left on device"

  • To: xen-users@xxxxxxxxxxxxx
  • From: FÃlix Barbeira <fbarbeira@xxxxxxxxx>
  • Date: Fri, 8 May 2015 08:42:33 +0200
  • Delivery-date: Fri, 08 May 2015 06:44:24 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

I answer myself. I checked the source code of "xenpvnetboot" and debugged some variables. The program tries to download pxe files to this directory:


dom0 has only 1G RAM size, so ubuntu gives the "/run/" partition this size:

# df -hl /run
Filesystem  ÂSize Used ÂAvail Used% Mount on
tmpfs       75M  1,1M  73M  2% /run

So the program exits with the right error message. Checking the source code I saw an option called "--output-directory". So I added the following option to the xen cfg file:

bootloader_args = [ '--output-directory=/tmp/' ]

And it worked fine.

2015-05-07 21:28 GMT+02:00 FÃlix Barbeira <fbarbeira@xxxxxxxxx>:
I want to load a vm using the bootloader "xenpvnetboot" following the instructions from http://wiki.xen.org/wiki/Xenpvnetboot . This is the cfg file:

bootloader = 'xenpvnetboot'
kernel = 'http://stable.release.core-os.net/amd64-usr/current/coreos_production_pxe.vmlinuz'
ramdisk = 'http://stable.release.core-os.net/amd64-usr/current/coreos_production_pxe_image.cpio.gz'
name = "coreos02"
memory = "1024"
vcpus = 2
vif = [ 'ip= ,mac=00:16:3e:23:33:d2,bridge=sw0' ]
disk = [ 'phy:/dev/vg0/coreos02-disk,xvda,w' ]

But when I try to boot the vm with "xl create coreos.cfg -c" I see the following in the log:

Traceback (most recent call last):
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 1094, in _retrieve
IOError: [Errno 28] No space left on device
Traceback (most recent call last):
 File "/usr/lib/xen-4.4/bin/xenpvnetboot", line 293, in <module>
 File "/usr/lib/xen-4.4/bin/xenpvnetboot", line 265, in main
  ramdisk = fetcher.get_file(opts.ramdisk)
 File "/usr/lib/xen-4.4/bin/xenpvnetboot", line 94, in get_file
  return urlgrabber.urlgrab(url, local_name, copy_local=1)
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 618, in urlgrab
  return default_grabber.urlgrab(url, filename, **kwargs)
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 982, in urlgrab
  return self._retry(opts, retryfunc, url, filename)
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 886, in _retry
  r = apply(func, (opts,) + args, {})
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 968, in retryfunc
  fo = PyCurlFileObject(url, filename, opts)
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 1063, in __init__
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 1355, in _do_open
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 1485, in _do_grab
 File "/usr/lib/python2.7/dist-packages/urlgrabber/grabber.py", line 1280, in _do_perform
  raise KeyboardInterrupt

The package urlgrabber is installed. I tried to wget the http links on the dom0 and worked fine. There is space more than enough in the dom0 and the in the lvm partition. I'm using ubuntu 14 with the xen 4.4 installed from the ubuntu repository. Anybody knows what is happening?

FÃlix Barbeira.

FÃlix Barbeira.
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.