[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] "xl create" hangs

  • To: xen-users@xxxxxxxxxxxxx
  • From: QI Wen <qiwen@xxxxxxxxxx>
  • Date: Thu, 10 Sep 2015 18:31:29 -0400
  • Delivery-date: Thu, 10 Sep 2015 22:32:49 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

Hi, all,

Just now, updated the XEN debug level to "all" and tried "xl -v create" again, still no output exceptÂ"Parsing config from xen2.cfg".

But I found that, with "dmesg", I got "task xenconsoled:1218 blocked for more than 120 seconds." and "task xl:1370 blocked for more than 120 seconds.", as shown in bellow. The complete log can be found in the attachments.

[ Â842.619806] INFO: task xenconsoled:1218 blocked for more than 120 seconds.
[ Â842.619896] Â Â Â Not tainted 3.19.0-26-generic #28~14.04.1-Ubuntu
[ Â842.619962] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ Â842.620043] xenconsoled   D ffff8803ff17be78   0 Â1218   Â1 0x00000000
[ Â842.620061] Âffff8803ff17be78 ffff8803ff108000 0000000000013e80 ffff8803ff17bfd8
[ Â842.620067] Â0000000000013e80 ffff8804032ba740 ffff8803ff108000 ffff880004f8b068
[ Â842.620073] Âffff880004f8b048 ffff880004f8b04c ffff8803ff108000 00000000ffffffff
[ Â842.620080] Call Trace:
[ Â842.620098] Â[<ffffffff817b2a09>] schedule_preempt_disabled+0x29/0x70
[ Â842.620106] Â[<ffffffff817b46f5>] __mutex_lock_slowpath+0x95/0x100
[ Â842.620113] Â[<ffffffff817b4783>] mutex_lock+0x23/0x37
[ Â842.620120] Â[<ffffffff8120a461>] __fdget_pos+0x41/0x50
[ Â842.620130] Â[<ffffffff811ed01f>] SyS_write+0x1f/0xb0
[ Â842.620137] Â[<ffffffff817b688d>] system_call_fastpath+0x16/0x1b
[ Â842.620145] INFO: task xl:1370 blocked for more than 120 seconds.
[ Â842.620209] Â Â Â Not tainted 3.19.0-26-generic #28~14.04.1-Ubuntu
[ Â842.620274] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
[ Â842.620354] xl       ÂD ffff8803fd89be78   0 Â1370  1356 0x00000004
[ Â842.620360] Âffff8803fd89be78 ffff8803ff109d70 0000000000013e80 ffff8803fd89bfd8
[ Â842.620365] Â0000000000013e80 ffffffff81c1d4e0 ffff8803ff109d70 0000000000000000
[ Â842.620371] Âffff880004107848 ffff88000410784c ffff8803ff109d70 00000000ffffffff
[ Â842.620377] Call Trace:
[ Â842.620384] Â[<ffffffff817b2a09>] schedule_preempt_disabled+0x29/0x70
[ Â842.620390] Â[<ffffffff817b46f5>] __mutex_lock_slowpath+0x95/0x100
[ Â842.620400] Â[<ffffffff81084f01>] ? do_sigaction+0x111/0x210
[ Â842.620406] Â[<ffffffff817b4783>] mutex_lock+0x23/0x37
[ Â842.620411] Â[<ffffffff8120a461>] __fdget_pos+0x41/0x50
[ Â842.620418] Â[<ffffffff811ed01f>] SyS_write+0x1f/0xb0
[ Â842.620425] Â[<ffffffff817b688d>] system_call_fastpath+0x16/0x1b

Logs with "xl dmesg" are also attached, in which many logs like "(XEN) traps.c:2514:d0 Domain attempted WRMSR *** from *** to ***" are found.

Could anyone please help to check these logs and give some suggestions? Thank you very much.

Wen QI

On Thu, Sep 10, 2015 at 4:37 PM, QI Wen <qiwen@xxxxxxxxxx> wrote:
Hi all,

I have Xen 4.4.0 installed on one Dell OptiPlex 9020 with Ubuntu 14.04.3.

Xen is installed from the source code. Domain-0 works well. But when I tried to launch a VM with "xl create", it hung after printing "Parsing config from xen2.cfg".

Could anyone give me some hints about how to locate the issue? I checked /var/log/xen/*.log, no related logs to "xl create".

Thank you very much.


Attachment: dmesg.txt
Description: Text document

Attachment: xl.dmesg.txt
Description: Text document

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.