[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Error compiling Xen in configuring stubdom/gmp with glibc-2.23 on Arch Linux

  • To: xen-users@xxxxxxxxxxxxx
  • From: Peter Milesson <miles@xxxxxxxx>
  • Date: Mon, 14 Mar 2016 20:59:56 +0100
  • Delivery-date: Mon, 14 Mar 2016 20:01:40 +0000
  • List-id: Xen user discussion <xen-users.lists.xen.org>

On 7. 3. 2016 1:38, John Thomson wrote:

I am encountering an error compiling Xen (4.6.1) in configuring
stubdom/gmp on x86_64 Arch Linux.
I think it may be due to the system's glibc-2.23. System gcc is 5.3.0.
Compiling was working fine before these system packages were updated.
Other packages were updated at the same time, so I am not sure which to

checking size of unsigned short... configure: error: cannot compute
sizeof (unsigned short)
See `config.log' for more details.
Makefile:170: recipe for target 'gmp-x86_64' failed
make[1]: *** [gmp-x86_64] Error 77

Analysing the error in the configure test program, ferror after fprintf
always returns 1.
The program still appears to function as intended, and outputs the
unsigned short size to conftest.val.
Appending a clearerr(f) after the fprintf (f, ...) calls appears to

When compiling the test program using system includes and libraries,
ferror returns 0.

My guess is that this may be due to using newlib cross-root includes and
the system’s glibc libraries.
I have not yet worked out how to resolve this. I have not been able to
work out how to use -nostdlib and the cross-root libraries. I get errors
for undefined functions.
Could I get some help resolving this, or where can I go from here?

The source for the configure test program and the gcc command configure
used to compile should be here:

NixOS also appears to have run into this error:

Thank you,
   John Thomson

Xen-users mailing list

I have got this error also with Xen-4.6.1. Identical.

I made a complete update of the computer, latest everything, incl. glibc-2.23, and gcc 5.3.0, kernel 4.4.4. It didn't work. Wiped everything and went back to glibc-2.17, and gcc 4.8.2. It did not help. It still refuses to compile. Running config and make on gmp separately, no problem.

I finally built Xen with --disable-stubdom, which worked.

Seems that the problem not necessarily is in glibc, but elsewhere.

The machine is based on Slackware 14.1, I tried the bleeding edge (almost 14.2), but backed down to a standard 14.1 (which is well over 2 years old). I'm using one of the latest kernels, 4.4.5, for dom0.

CPU AMD FX-6100, 16GB RAM, AMD 990FX Chipset, AMD Radeon HD6450 (graphics pass through), file system LVM-based.

Best regards,


Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.