[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] UEFI-booted Xen turns into black screen after boot


I tried getting Xen running on my system (Debian Testing, 64-bit, UEFI only :( ) however I continuously get stuck after loading the kernel. I've added Xen.efi to /boot/efi/EFI/Xen and made an EFI boot configuration for it too - it loads the kernel, does something really fast (can't even read it with a camera) and then it just goes to a black screen.

System Info:
- /proc/version: Linux version 4.4.0-1-amd64 (debian-kernel@xxxxxxxxxxxxxxxx) (gcc version 5.3.1 20160307 (Debian 5.3.1-11) ) #1 SMP Debian 4.4.6-1 (2016-03-17)
- /proc/cmdline: BOOT_IMAGE=/boot/vmlinuz-4.4.0-1-amd64 root=UUID=a393c438-34cb-4237-be26-986ce78e960b ro quiet
- /boot/efi/EFI/Xen/xen.cfg: http://pastebin.com/UGPnhz8x

Hardware Info (if necessary):
- ASRock 970 Pro3
- 2x 1TB HDD in UEFI-RAID configuration (no SATA/AHCI boot possible with this)
- AMD Radeon R9 285 with AMDGPU + mesa drivers

I feel like I missed a critical step - like a configuration file somewhere that tells Xen what to do. I couldn't find anything about this issue but I think that's cause my search-fu is weak. I hope someone can help me here - I tried finding log files but it doesn't look like any are created.


Michael Fabian Dirks
Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.