[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-users] How to install Xen on Fedora 23?

I installed Fedora 23 x64 on my PC and id below command for installing Xen :

# cd /etc/yum.repos.d/
# wget http://fedorapeople.org/groups/virt/...t-preview.repo
# yum update
# yum -y install xen xen-hypervisor xen-libs xen-runtime
# systemctl enable xend.service
# systemctl enable xendomains.service

After it I run below command :

# grep ^menuentry /boot/grub2/grub.cfg | cut -d "'" -f2
Fedora (4.4.7-300.fc23.i686) 23 (Workstation Edition)
Fedora (4.2.3-300.fc23.i686) 23 (Workstation Edition)
Fedora (0-rescue-204e260309794cee901bd6e0b46ace3a) 23 (Workstation Edition)

But, I can't see any "Fedora, with Xen hypervisor" !!! and when I run "xl info" 
it show me below error :

# xl info
xc: error: Could not obtain handle on privileged command interface (2 = No such 
file or directory): Internal error
libxl: error: libxl.c:114:libxl_ctx_alloc: cannot open libxc handle: No such 
file or directory
cannot init xl context

How can I solve it?

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.