[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] kexec Xen from Linux


>> Has anyone tried kexec of Xen from a booted linux ?
>> I tried with a xen 4.7 image I built (and that boots perfectly from
>> grub) but kexec just segfaults on it ...
> I've done so before, but not recently.  My guess would be that your version
> of kexec isn't built with Xen support (I'm not sure how to check on anything
> but Gentoo, but if you build it locally, there's a switch for ./configure to
> enable Xen support).

Isn't that needed only for kexec _from_ Xen ?

I'm not going Xen -> Xen, I'm doing vanilla linux -> xen.

In any case, I tried rebuilding with xen support (and I see kexec now
linking to the xen libs) and same results.

Tracing this a bit further, it seems to segfault when pasing the
".note" section of the ELF which wasn't present in older xen. Seems
it's been added for the "live patching" support IIRC.

If I give it a binary where I stripped the .note section, then kexec
accepts to load it, but trying to exec it just reboots the server. Not
sure how to debug that now.



Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.