[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

re: oasis setup error for xen


Thanks for your help. I have successfully run the "hello" example in Xen. 

About mirage-www, I disabled the "Target" line and oasis works fine.
However, when I make mirage-www in 4.00.1+mirage-xen, it said "ocamlfind:
Package `cohttp.mirage' not found". This is strange because I have done the
same thing in 4.00.1+annot. I ran "ocamlfind query cohttp.mirage" in both
systems, and got different results (shown below). Is it a bug for cohttp in

In 4.00.1+mirage-xen:
root@zym:~# ocamlfind query cohttp.mirage
ocamlfind: Package `cohttp.mirage' not found
root@zym:~# ocamlfind query cohttp

In 4.00.1+annot:
root@zym:~# ocamlfind query cohttp.mirage
root@zym:~# ocamlfind query cohttp

I tried to work around it by changing "cohttp.mirage" to "cohttp" in _oasis,
but unfortunately another problem occurred: "Error: Unbound module

Merry Christmas!

发件人: Anil Madhavapeddy [mailto:anil@xxxxxxxxxx] 
发送时间: 2012年12月24日 2:18
收件人: Yiming Zhang
抄送: cl-mirage@xxxxxxxxxxxxxxx
主题: Re: oasis setup error for xen

Hi Yiming,

The OASIS setup isn't needed as the files that are autogenerated are also
checked in, so it should compile straight from a checkout.  However, read on
to find out more...

The OASIS in question is actually a patched version that supports the
'Executable: xen' target, from github.com/avsm/oasis (add-xen branch).
We're currently upstreaming only a portion of this patch:

...which is sufficient to output a standalone native object file. This uses
the -output-obj facility of the OCaml compiler to link all the OCaml modules
into one native code blob, but to not output a final binary.  This lets us
do the final link under more controlled conditions.

Recent versions of mirage-platform then bring back the `mir-build` script,
which converts the native object file into a Xen microkernel.  This two-step
process makes it far easier to incorporate other backends such as the
kFreeBSD target in the future.

The 'hello world' Mirage skeleton is in:

I'm assembling a bit more detail in the README there (and hopefully Jon
Ludlam will commit a suspend/resume-aware version into that repository after
the holidays too).  Once these new scripts settle down and the OASIS patch
is upstreamed, I'll sync mirage-www with it.


On 22 Dec 2012, at 21:23, Yiming Zhang <sdiris@xxxxxxxxx> wrote:

> Dear all,
> I am trying to compile mirage-www for running directly in xen. However,
when I run “oasis setup” (I guess it is needed), I got the following
> root@zym:~/src/mirage-www/src# oasis setup
> E: Field Target is not defined in schema Executable
> I checked the _oasis file and found one line:
> Target:             xen
> But it seems oasis doesn’t support the “Target” field. Anyone knows the
> Thanks!
> Yiming



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.