[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with tuntap while building mirage-www

Hi everyone,

I'm going through the Mirage install instructions to build the mirage website 
and hit a tuntap related problem.  I installed tuntap via `brew install tuntap` 
and went through some of the brew caveats (i.e a few `sudo cp` and `sudo chown` 

Some notes:
- My compiler switch is OCaml 4.01.0 RC2 (ie I varied from the instructions by 
doing `opam switch mirage-unix -a 4.01.0` instead)

- I'm trying to use the mirage network stack so I ran...
$ make clean unix-direct-build      # this seems to work fine
$ sudo make run                              # this produces the output below

… but I have the same error with unix-socket-build.  Not sure what I've done 
wrong with tuntap.  
What can I try next?  


amir$ sudo make run
cd src && sudo mirari run www.conf 
[mirari] Using specified config file www.conf
[mirari] + unix direct mode
[mirari] Creating tap0 interface.
[mirari] Ctrl-C received, killing child and exiting.

[mirari] Tuntap failed with error No such file or directory. Remember that 
mirari has to be run as root have the CAP_NET_ADMIN capability in order to be 
able to run unikernels for the UNIX backendmirari: internal error, uncaught 
        Failure("No such file or directory")
make: *** [run] Error 1





Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.