[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with tuntap while building mirage-www


Short answer: I rebooted (haven't had to do that in a while for an install to 
work, hence didn't think about it)

Longer answer: Getting tuntap via homebrew is fine but there's extra work in 
moving files to the appropriate places. This is pointed out in the Caveats and 
I'd already followed those instructions, namely copying and chown-ing files 
from Cellar into `/Library/Extensions/` and `/Library/StartupItems/` (nb: you 
can see the instructions I'm referring to via `brew info tuntap`)

Since the README in the downloadable pkg mentioned the same file locations, I 
guessed that a reboot was required to give the stuff in StartupItems a kick (I 
guessed based on the name of the folder).  That seems to have worked.  I assume 
installing via the pkg tells you that you need to restart.


On 10 Sep 2013, at 15:46, Anil Madhavapeddy <anil@xxxxxxxxxx> wrote:

> This indicates that the tuntap MacOS X kext hasn't been installed correctly.  
> I dont know if the tuntap Homebrew package installs the kext, as the homepage 
> has an Mpkg installer which installs the kernel module for you.
> -anil
> On 10 Sep 2013, at 14:53, Amir Chaudhry <amc79@xxxxxxxxx> wrote:
>> Hi everyone,
>> I'm going through the Mirage install instructions to build the mirage 
>> website and hit a tuntap related problem.  I installed tuntap via `brew 
>> install tuntap` and went through some of the brew caveats (i.e a few `sudo 
>> cp` and `sudo chown` steps).
>> Some notes:
>> - My compiler switch is OCaml 4.01.0 RC2 (ie I varied from the instructions 
>> by doing `opam switch mirage-unix -a 4.01.0` instead)
>> - I'm trying to use the mirage network stack so I ran...
>> $ make clean unix-direct-build      # this seems to work fine
>> $ sudo make run                              # this produces the output below
>> … but I have the same error with unix-socket-build.  Not sure what I've done 
>> wrong with tuntap.  
>> What can I try next?  
>> ============================
>> amir$ sudo make run
>> cd src && sudo mirari run www.conf 
>> [mirari] Using specified config file www.conf
>> [mirari] + unix direct mode
>> [mirari] Creating tap0 interface.
>> /dev/tap0
>> [mirari] Ctrl-C received, killing child and exiting.
>> [mirari] Tuntap failed with error No such file or directory. Remember that 
>> mirari has to be run as root have the CAP_NET_ADMIN capability in order to 
>> be able to run unikernels for the UNIX backendmirari: internal error, 
>> uncaught exception:
>>       Failure("No such file or directory")
>> make: *** [run] Error 1
>> amir$ 
>> ============================
>> Amir



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.