[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[MirageOS-devel] Regarding Bisect Coverage Bugs on ubuntu12.04 platform

Hello Mirage Developers,
                                 As Part of My interest to get in to GSOC 2014 ,I was asked to gain some experience on performing tests using various package available in OCAML website on mirage OS .
                                    I am trying to use bisect coverage tool on ocam-uri package which i got from git hub , i am getting some unbound module errors though i tried all the possible methods mentioned in the bisect document .

I installed bisect package by two methods  
             1.using opam package manager and 
             2.even i tried using manual installation specified in the doc in both the cases                 i am getting errors.

my opam package manager path is /home/narya/.opam/system/lib/bisect ---this is the place where all required pre-processor files are there

ocam-uri package which i downloaded using git clone is in ---/home/narya/ocaml/ocaml-uri/lib_test/test_runner.ml 

when i am trying to compile and instrument the above ocaml-uri test runner file using the methods mentioned in bisect doc ,the following are some errors i am facing 

narya@ubuntu:~/ocaml/ocaml-uri/lib_test$ ocamlc -I +bisect /home/narya/.opam/system/lib/bisect/bisect.cma test_runner.ml

The following is the error i am getting 

Unbound module oUnit 

Though there is OUint package in opam directory 

and when i tried to run the same file by mentioning other path where i placed bisect files ----/usr/lib/ocaml/bisect ----here i installed bisect package manually by executing commands specified in the doc 

Here i am getting Unbound module Bisect ..

I would be happy if some one address the above issues.........

Thanks and Regards,
Y.Narayana Reddy,
MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.