[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [MirageOS-devel] Regarding Bisect Coverage Bugs on ubuntu12.04 platform

hi narayana;

apologies -- i'm having trouble following what you're trying to do here. could 
you point to the instructions you're following?

in terms of paths, i presume you've made sure you executed "eval $(opam config 
env)" to make sure paths are correct?

what are the specific opam packages you have installed?

On 10 Mar 2014, at 21:44, Narayana Reddy Y <narayana1208@xxxxxxxxxxx> wrote:

> Hello Mirage Developers,
>                                  As Part of My interest to get in to GSOC 
> 2014 ,I was asked to gain some experience on performing tests using various 
> package available in OCAML website on mirage OS .
>                                     I am trying to use bisect coverage tool 
> on ocam-uri package which i got from git hub , i am getting some unbound 
> module errors though i tried all the possible methods mentioned in the bisect 
> document .
> I installed bisect package by two methods  
>              1.using opam package manager and 
>              2.even i tried using manual installation specified in the doc in 
> both the cases                 i am getting errors.
> my opam package manager path is /home/narya/.opam/system/lib/bisect ---this 
> is the place where all required pre-processor files are there
> ocam-uri package which i downloaded using git clone is in 
> ---/home/narya/ocaml/ocaml-uri/lib_test/test_runner.ml 
> when i am trying to compile and instrument the above ocaml-uri test runner 
> file using the methods mentioned in bisect doc ,the following are some errors 
> i am facing 
> narya@ubuntu:~/ocaml/ocaml-uri/lib_test$ ocamlc -I +bisect 
> /home/narya/.opam/system/lib/bisect/bisect.cma test_runner.ml
> The following is the error i am getting 
> Unbound module oUnit 
> Though there is OUint package in opam directory 
> and when i tried to run the same file by mentioning other path where i placed 
> bisect files ----/usr/lib/ocaml/bisect ----here i installed bisect package 
> manually by executing commands specified in the doc 
> Here i am getting Unbound module Bisect ..
> I would be happy if some one address the above issues.........
> -- 
> Thanks and Regards,
> Y.Narayana Reddy,
> http://member.acm.org/~narayanareddy3 
>       IIIT-Delhi
> _______________________________________________
> MirageOS-devel mailing list
> MirageOS-devel@xxxxxxxxxxxxxxxxxxxx
> http://lists.xenproject.org/cgi-bin/mailman/listinfo/mirageos-devel



This message and any attachment are intended solely for the addressee and may 
contain confidential information. If you have received this message in error, 
please send it back to me, and immediately delete it.   Please do not use, copy 
or disclose the information contained in this message or in any attachment.  
Any views or opinions expressed by the author of this email do not necessarily 
reflect the views of the University of Nottingham.

This message has been checked for viruses but the contents of an attachment
may still contain software viruses which could damage your computer system, you 
are advised to perform your own checks. Email communications with the 
University of Nottingham may be monitored as permitted by UK legislation.

MirageOS-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.