[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [win-pv-devel] Win-pv driver install success fails to boot

There’s a multitude of reasons why your VM may not be booting after messing with the config. You haven’t actually said how it is failing but, since you do have testsigning enabled, my next guess is that you are getting a 0x7B blue screen at boot time. If so, this is because the XENFILT filter driver is still installed and is instructing QEMU to unplug emulated devices at boot time.

To stop it from doing this you have a couple of options:


-          Find all the instances of UpperFilters where XENFILT is specified (under HKLM/System/CurrentControlset/Control/Class) and remove them.

-          Look under HKLM/System/CurrentControlSet/Services/XEN/Unplug and remove any DISKS value you may find there.


Once you have done one or both of these you should be able to reboot your VM and emulated devices will stay plugged.


The PV drivers log to QEMU, if you are running qemu trad, you should see output in the qemu log file. If you are running upstream QEMU you’ll need to enable the xen_platform_log event before you get any logging.





From: chris [mailto:tknchris@xxxxxxxxx]
Sent: 24 July 2016 04:39
To: Paul Durrant
Cc: win-pv-devel@xxxxxxxxxxxxxxxxxxxx
Subject: Re: [win-pv-devel] Win-pv driver install success fails to boot


OK. I changed the config back and i still cant boot. I did have testsigning enabled and rebooted twice before attempting to install the drivers. 

Any idea why windows cant boot? I followed the instructions to the letter so I am trying to understand why its not working.


Also, even though I could reinstall I'd like to work through getting the drivers disabled / uninstalled and get things booting again so I am familiar with this process. I don't really think its wise to just reinstall then down the line deploy this into production and have something like this happen and not have any solution other than reinstalling.


I have tried:

- tried booting in safe mode 

- tried startup repair

- tried booting into a command prompt and tried renaming all the xen*.sys files in c:\windows\system32\drivers\

- tried booting into command prompt and doing bootrec /fixboot, bootrec /fixmbr, bootrec /rebuildbcd



Whats the process to reverse the installation and get windows to boot?





On Fri, Jul 22, 2016 at 4:45 AM, Paul Durrant <Paul.Durrant@xxxxxxxxxx> wrote:

Hi Chris,


  Don’t mess with the disk and network lines in your config. You still need emulated disk to boot Windows as the firmware (SeaBIOS or ROMBIOS) does not have PV frontends. Once Windows starts and the PV drivers load they will instruct QEMU to unplug the emulated devices so that the PV devices can take their place.


  As for recovering, it’s probably going to be tricky. Since you were doing a fresh install it’s probably quicker to start again. The other thing to do *before* you install PV drivers (and I suspect this is the root of your problem) is to enable test signed drivers in Windows. Windows 10 (even 32-bit) will not load test signed drivers unless you have done:


bcdedit /set testsigning on


  Hope that helps,




From: win-pv-devel [mailto:win-pv-devel-bounces@xxxxxxxxxxxxxxxxxxxx] On Behalf Of chris
Sent: 21 July 2016 14:31
To: win-pv-devel@xxxxxxxxxxxxxxxxxxxx
Subject: [win-pv-devel] Win-pv driver install success fails to boot




I am a previous gplpv user who recently came across this project and wanted to give a try to atleast help provide feedback and testing.


I downloaded the latest drivers via the tar files on this page:



I extracted and ran dpinst as noted in the readme txt  for each driver and saw that in device manager it created some new devices. NOTE this is a clean install and did not have gplpv or any other drivers previously 

I shutdown the domu, changed my disk and network lines to use the PV style:




vif = ['type=netfront, bridge=xenbr0, mac=00:16:3D:37:A0:A3']


and when i tried to start it up, it gets stuck at windows 10 loading screen with the logo and the spinning wheel underneath. i left it for several hours and it never got any further nor did it bsod'd or reboot over and over.


i went  back and changed my config back to emulated interfaces and windows 10 does not start via the original config either


did i miss some critical step(s)? any ideas why the OS wont boot? whats he best to remove the drivers and try again?


i am a fairly technical linux and windows user and willing to invest some time to anything that will help so please let me know if theres any more info or anything i can do to give you more data


the dom0 is a up to date debian jessie, xl info gives:

release                : 3.16.0-4-amd64

version                : #1 SMP Debian 3.16.7-ckt11-1+deb8u5 (2015-10-09)

machine                : x86_64

nr_cpus                : 12

max_cpu_id             : 15

nr_nodes               : 2

cores_per_socket       : 12

threads_per_core       : 1

cpu_mhz                : 2100

hw_caps                : 178bf3ff:efd3fbff:00000000:00001300:00802001:00000000:000837ff:00000000

virt_caps              : hvm

total_memory           : 57342

free_memory            : 16455

sharing_freed_memory   : 0

sharing_used_memory    : 0

outstanding_claims     : 0

free_cpus              : 0

xen_major              : 4

xen_minor              : 4

xen_extra              : .1

xen_version            : 4.4.1

xen_caps               : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64 

xen_scheduler          : credit

xen_pagesize           : 4096

platform_params        : virt_start=0xffff800000000000

xen_changeset          : 

xen_commandline        : placeholder dom0_mem=1024M

cc_compiler            : gcc (Debian 4.9.2-10) 4.9.2

cc_compile_by          : ultrotter

cc_compile_domain      : debian.org

cc_compile_date        : Thu Jun 11 18:24:17 EEST 2015

xend_config_format     : 4




win-pv-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.