[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] Trying to follow the xcp build instructions

  • To: "xen-api@xxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxx>
  • From: Nathan March <nathan@xxxxxx>
  • Date: Mon, 24 Jun 2013 16:19:19 -0700
  • Delivery-date: Mon, 24 Jun 2013 23:20:15 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gt.net; h=message-id:date :from:mime-version:to:subject:content-type :content-transfer-encoding; q=dns; s=mail; b=XJzRyXDQmXldItb2EaS 27Uz4c3ruCwQdGr5awCLcwk+efeU16qIHAqlYCywvI/X6t/Ez9/TJSSgl2LvxEpI yIqgCd5Xfv1kLsDZ0GDPFneWDGd9kSXlcr3FHTj4ZETLEmQCrENK8WkzJ5xLA7jf h2yjDRrmSfVSRkIdgzLA5ypg=
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>

Hi All,

Trying to follow the xcp build instructions: http://wiki.xen.org/wiki/XCP_Building_Instructions

I'm running into what appears to be legacy naming from the libxcpvhd rename to libvhd:

[root@xcptest-build xen-api]# make
omake -j 8 phase1
*** omake: reading OMakefiles
*** omake: finished reading OMakefiles (1.17 sec)
--- Checking for ocamlfind... (found /root/.opam/4.00.1/bin/ocamlfind)
--- Checking for ocamlc.opt... (found /root/.opam/4.00.1/bin/ocamlc.opt)
--- Checking for ocamlopt.opt... (found /root/.opam/4.00.1/bin/ocamlopt.opt)
--- Checking whether ocamlc understands the "z" warnings... (yes)
*** omake: done (19.29 sec, 39/39 scans, 54/115 rules, 211/605 digests)
omake -j 8 phase2
*** omake: reading OMakefiles
*** omake: finished reading OMakefiles (0.28 sec)
- scan ocaml/xapi scan-ocaml-xapi_inventory.ml
+ ocamlfind ocamldep -package oclock,xml-light2,cdrom,pciutil,sexpr,log,stunnel,http-svr,xen-utils,netdev,tapctl,rpclib,nbd.unix,xenstore-compat,xenctrl,uuid,gzip,libxcpvhd,sha1,xenctrl,xenctrlext,xenstore-compat,cpuid -native -I ../idl -I ../idl/ocaml_backend -I ../autogen -I ../database/ -I ../xenops -I ../xva -I ../util -I ../auth -I ../license -I ../client_records -I ../rfb -I ../gpg -I ../network -I ../rrdd/interface -I .. xapi_inventory.ml
ocamlfind: Package `libxcpvhd' not found

I've tried both jonludlam and johngarbutt's git repos, is there a more up to date repo that I should be using?

Tried just updating the ocaml/xapi/OMakefile but got stuck here:

+ ocamlfind ocamlopt -package oclock,xml-light2,sexpr,stunnel,http-svr,netdev,rpclib,threads,xenctrl,xenstore-compat,xenctrlext,stdext,log,cdrom,netdev,oUnit,uuid -g -dtypes -thread -warn-error +a-4-6-9-27-28-29 -thread -ccopt -fPIC -I ../xapi -I ../util -I .. -c netman.ml
File "netman.ml", line 30, characters 7-22:
Error: Unbound value Xenctrl.is_fake


Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.