[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] Compiling xapi toolstack on debian 7


The same problem occurred when I was building XAPI on debian unstable.

As xen 4.2 is available as well on debian unstable I tried building against it and this compiled without to much trouble.
But the result of this build wasn't exactly what I had been expecting since a lot seemed missing. 
There were no init.d scripts to be found for xapi, running xapi from the commandline would ask me for the location of xapissl and others which were nowhere to be found.
The path's used by xapi were somewhat chaotic, some were relative to the opam directory and some were absolute paths.

It was at this point I gave up as well.

Jorgen Evens
Erfkensstraat 10, 3990 Peer - Belgium
+32 496 629682

2013/6/25 Sébastien RICCIO <sr@xxxxxxxxxxxxxxx>
On 25.06.2013 17:44, Sébastien RICCIO wrote:

On 25.06.2013 11:51, Dave Scott wrote:

I'm trying to compile xapi on a debian 7 box. With some efforts I managed to
get almost all the dependencies resolved in order to be able to compile it
except this one that I'm stuck with:

xenlight/xenlight_stubs.c:30:19: fatal error: libxl.h: No such file or directory
It looks like the debian package libxen-dev doesn't include the libxl header.

In the short-term we can work-around this by conditionally compiling the xenlight code in ocaml-xen-lowlevel-libs. In the longer term we really need to get that package fixed!


Thanks for your answer.

Okay for the moment I tried to work around it by getting the hypervisor sources with apt-get source xen-hypervisor-4.1-amd64.

I was able to find libxl.h and libxl_uuid.h but now it's stuck to:

_libxl_types.h included by libxl.h

I have no clue where to find this one :)


Xen-api mailing list

Okay I found it was autogenerated while compiling tools/libxl from the hypervisor sources, but now I'm stuck to this, I think this time I'll give up and wait that changes are made to the repo :)

### stdout ###
xenlight/xenlight_stubs.c:3702:7: error: request for member ‘disaster’ in something not a structure or union
xenlight/xenlight_stubs.c:3704:2: warning: implicit declaration of function ‘libxl_event_register_callbacks’ [-Wimplicit-function-declaration]
xenlight/xenlight_stubs.c:3704:2: error: unknown type name ‘libxl_event_hooks’
xenlight/xenlight_stubs.c:3706:5: error: ‘libxl_event_hooks’ undeclared (first use in this function)
xenlight/xenlight_stubs.c:3706:25: error: expected _expression_ before ‘)’ token
xenlight/xenlight_stubs.c: In function ‘stub_libxl_evenable_domain_death’:
xenlight/xenlight_stubs.c:3714:2: error: unknown type name ‘libxl_evgen_domain_death’
xenlight/xenlight_stubs.c: At top level:
xenlight/xenlight_stubs.c:2656:12: warning: ‘event_val’ defined but not used [-Wunused-function]

Command exited with code 2.
### stderr ###
E: Failure("Command ''/root/.opam/4.00.1/bin/ocamlbuild' lib/libxenctrl_stubs.a lib/dllxenctrl_stubs.so lib/xenctrl.cma lib/xenctrl.cmxa lib/xenctrl.a lib/xenctrl.cmxs lwt/xenctrl_lwt.cma lwt/xenctrl_lwt.cmxa lwt/xenctrl_lwt.a lwt/xenctrl_lwt.cmxs xenlight/libxenlight_stubs.a xenlight/dllxenlight_stubs.so xenlight/xenlight.cma xenlight/xenlight.cmxa xenlight/xenlight.a xenlight/xenlight.cmxs xenli...[truncated]


Xen-api mailing list

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.