[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-API] Upgrading xcp 1.6 to xenserver 6.2 issues

  • To: "xen-api@xxxxxxxxxxxxx" <xen-api@xxxxxxxxxxxxx>
  • From: Nathan March <nathan@xxxxxx>
  • Date: Wed, 17 Jul 2013 16:40:01 -0700
  • Delivery-date: Wed, 17 Jul 2013 23:41:12 +0000
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gt.net; h=message-id:date :from:mime-version:to:subject:content-type :content-transfer-encoding; q=dns; s=mail; b=L7uDxveaCCaYEYVa5A4 9uY59MZtqcbzL53h0MMhnvGbv4oFoeJy2VEALTWydkuygKb0LJ2T4aOHvfYSBs7z BpsZzbkylwK9v0gQ53aMgqFQLKIB381wCYEtS25LG+HH8McChacPL6kgUKYEnPEL +f+PP2W6bcMpyvfJBZ2kgI7U=
  • List-id: User and development list for XCP and XAPI <xen-api.lists.xen.org>

Hi All,

Upgraded one of our clusters from xcp 1.6 to xenserver 6.2 just fine, but trying to do one of our others and I'm running into a whole slew of weird problems.

Steps I did:

- With host #1 as the master, upgraded #3 to 6.2
- #3 lost access to the pool, was unable to get it resolved. Would show no network cards in xsconsole, even though ifconfig showed up fine and networking worked as well.
- Rebuilt host #3 as a brand new xs 6.2 install
- Tried to add to the pool, failed since it's a newer version. Logical enough.
- Promoted host #4 to be the master
- Rebooted #4 without promoting another host to master, then upgraded it to xs 6.2

At this point things appear to be working with the master host #4 on 6.2 and the rest are on 1.6.

Now the interesting things:

1) When I do a "xe-toolstack-restart" on the upgraded #4, xapi won't launch (bails out with errcode 1) and I can't see anything useful in the logs. Stracing xapi doesn't seem to reveal anything useful either. Rebooting the host restores everything fine.

2) Trying to add host #3 into the pool results in: "There was a problem with the license daemon (v6d). Is it running?" I've checked and v6d isn't running anywhere, nor is it running on my other 6.2 cluster. I assume this is a commercial xen daemon and not part of the opensource xenserver, but I'm not sure why it's trying to look for it?

I've reverted things back to 6.1 for now and will take another stab at this tomorrow, but anyone have any ideas on what I'm doing wrong?


- Nathan

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.