[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-API] The vdi is not available


When this happens, what does /var/log/SMlog says ?

Can you please tail -f /var/log/SMlog on both source and destination, try to migrate the VM and paste the results?


On 24.07.2013 23:09, Andres E. Moya wrote:
I also just tried creating a new storage repository moving the vdi to the new 
storage repository is successful, i then try to migrate it to server C and 
still have the same issue

Moya Solutions, Inc.
0 | 646-918-5238 x 102
F | 646-390-1806

----- Original Message -----
From: "Alberto Castrillo" <castrillo@xxxxxxxxxx>
To: "xen-api" <xen-api@xxxxxxxxxxxxx>
Sent: Wednesday, July 24, 2013 4:12:13 PM
Subject: Re: [Xen-API] The vdi is not available

We use NFS as shared storage, and have faced some "VDI not available" issues 
with our VMs. I haven't been able to start a VM with the method of that URL in XCP 1.6 
(in 1.1 and 1.5 beta worked). What worked for me:

- Detach the VDI from the VM
- Detach and forget the SR where the VDI is stored
- Reattach the forgotten SR (create new SR, give the same info that the 
detached SR, re-use the SR-UUID, ...)
- Reattach the VDI to the VM

El 24/07/2013, a las 21:10, hook escribiÃ:

Past weekend (as usual O_o) we have experienced the issue in our XCP 1.6 
production pool.
Shared iSCSI storage was shutted down due to misconfigured UPS settings while 
XCP servers continued to work.

When storage was returned to working state and reconnected to pool most VM did 
not boot with the same message - VDI is not available.
Googling give me mentioned above method - forgot and reconnect VDI.
Result was even worser - the whole SR become unusable.
Storage rescan gazered lot of errors like bad header on LVM and many other.

Finally i've disconnect failed SR from pool, connect it back and SR become 
healthy (it looks so). But anyone VM was not start with disk from this SR and 
freeze during startup.
I did not find solution and restored most VMs from backup (long live VMPP!)

So, i just wanna say - be highly careful with VDI on shared storage repository 
in production environment)

2013/7/24 Brian Menges < bmenges@xxxxxxxxxx >

Have you tried the following?: 

- Brian Menges
Principal Engineer, DevOps
GoGrid | ServePath | ColoServe | UpStream Networks

-----Original Message-----
From: xen-api-bounces@xxxxxxxxxxxxx [mailto: xen-api-bounces@xxxxxxxxxxxxx ] On 
Behalf Of Andres E. Moya
Sent: Wednesday, July 24, 2013 09:32
To: xen-api@xxxxxxxxxxxxx
Subject: [Xen-API] The vdi is not available

Guys need help trouble shooting this issue

I have an xcp 1.6 pool with 3 machines A,B, and C

I can migrate from A to B and B to A

WE cannot migrate from A or B to C, we also cannot shutdown a vm and start it 
up on C, when we do that we get the message The vdi is not available.

We have tried removing machine C from the pool and re joining and still have 
the issue.

when we first add host C to the pool it cannot load the nfs storage repository 
because we need to create a management interface from a bonded vlan that gets 
created after joining the pool. After we create the interface and run a re plug 
on the storage repository it says its connected / re plugged.

Thanks for any help in advance

Xen-api mailing list


The information contained in this message, and any attachments, may contain 
confidential and legally privileged material. It is solely for the use of the 
person or entity to which it is addressed. Any review, retransmission, 
dissemination, or action taken in reliance upon this information by persons or 
entities other than the intended recipient is prohibited. If you receive this 
in error, please contact the sender and delete the material from any computer.

Xen-api mailing list

Xen-api mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.