[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Re: Virtual block devices (vbd) still not working... :-(

There are now fixes to the vbd problems in the xen-unstable.bk
repository at xen.bkbits.net.

Please clone and build this repsoitory if you're having problems.

> This doesn't work for me. The problem is that vbd's are registered
> with the Linux blkdev layer at boot time, but we have no mechanism to
> properly attach new vbd's that are created after the domain has
> already booted.
> I really can't see how it could possibly have worked for you --- DOM0
> would have booted with no vbd's and there's no way to register them
> later!

I've fixed this now. If you attach a VBD to an already-running domain,
you should run tools/misc/xen_refresh_dev. 
e.g. 'xen_refresh_dev /dev/xvda'.

This refreshes Linux's view of its partition table, and also polls Xen
to find out the current parameters of the VBD. Without doing this,
Linux will never see the correct capacity for the VBD (it will
probably continue to think that it has zero size!).

A future TODO is probably to get Xen to automatically inform a domain
when one of its VBDs changes so that the refresh doesn't need to be
done manually.
> Something here is broke. 'vbd show' will show that the vbd is ro if
> you specify -w, but rw if you specify -rw. I'll have a look... 

This is fixed. -w is definitely the write way to get write privileges
on a new VBD.

 -- Keir

This SF.net email is sponsored by: SF.net Giveback Program.
SourceForge.net hosts over 70,000 Open Source Projects.
See the people who have HELPED US provide better services:
Click here: http://sourceforge.net/supporters.php
Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.